summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-28 00:06:13 +0000
committerSam James <sam@gentoo.org>2024-02-28 00:06:13 +0000
commit4f6ce3e29c1b9241d9f9b8a7cf432923fa3e1480 (patch)
treefd6a1ca0442d541cdacdd322b057a166ce7e8149 /net-dns
parentdev-ml/ounit2: Stabilize 2.2.7 arm, #925658 (diff)
downloadgentoo-4f6ce3e29c1b9241d9f9b8a7cf432923fa3e1480.tar.gz
gentoo-4f6ce3e29c1b9241d9f9b8a7cf432923fa3e1480.tar.bz2
gentoo-4f6ce3e29c1b9241d9f9b8a7cf432923fa3e1480.zip
net-dns/c-ares: add 1.27.0
Bug: https://bugs.gentoo.org/925661 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/c-ares/Manifest2
-rw-r--r--net-dns/c-ares/c-ares-1.27.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/net-dns/c-ares/Manifest b/net-dns/c-ares/Manifest
index 5688eb61fabf..265575fbdaac 100644
--- a/net-dns/c-ares/Manifest
+++ b/net-dns/c-ares/Manifest
@@ -2,3 +2,5 @@ DIST c-ares-1.25.0.tar.gz 1264129 BLAKE2B a4f4b493e1331ade27504238c3e520e1ffaa52
DIST c-ares-1.25.0.tar.gz.asc 488 BLAKE2B 45b07fc1ef14452b8a4fda63f134e389b66c120ccd8de3d48ccc5659c481db1796339a1968db406cf9b3da1a9c5aa81ccf538bc0546bb6c4babbe7de9c14f576 SHA512 9cf2dcd80807b54cd7fa6871283863384a4b6b10e0ef9c287bb4969a9169b7f12180a15c5fa756770c5ba01558ef48615aaaaefa546d19b3496e3cbe0454346b
DIST c-ares-1.26.0.tar.gz 1298394 BLAKE2B 9bcbb321b31518fdd3481447e1bba733dbf0eabd1876aa0fec6737888fd176b837c64e6b22ae5754a905f0fd1591d4fd516db558fafae92cc2684ad7e0c29f63 SHA512 81657b8b9840a565b04ecf87ef8f0fc3192a9594808e47aed5e5bbebf2b5f0066b0cd5fae70f0fe70b68d428b4cc75fba22d2ae7683c6d0f87979c414c072af1
DIST c-ares-1.26.0.tar.gz.asc 488 BLAKE2B 89c420ed235dce86c3d18ce62b58f50b78abf919c178e9a786fce5ee11da2b7a1314f8eb76bef20df0e43d18f636508540d9a9d2dfcd84df0c62691497f3a9a0 SHA512 84cd9918c22346a975400f17bf64e5093aa7b2d8f3377799cde5f6ab508e8f5ab6a004497747b702b7249b2b1369cdd22149519da01a405cf928806007e7a599
+DIST c-ares-1.27.0.tar.gz 1301440 BLAKE2B 112bf16288efc3ca1c69216de6bb42fdfc5348e70879321fb27f9602a8f469a21fa502a1cdd2f935e4ad0505ea7e22bd3a3326ce83bdb2acbe5ff266fc11cc6f SHA512 d0bffeeabdc5f1d4cececd46bd495b8224a64eaaf6d2a91c5475517440effe0e096146a1ebf19ece07367198be576c61b11961d5e4c3f601c5c5529ce4fcb46a
+DIST c-ares-1.27.0.tar.gz.asc 488 BLAKE2B 64798140a1d61e32ba45467034d9da75abd8f48810643947c94b04dcaae1b8c68da7a6d9acb7476808601acfe6a527b2cd855d99912f5ac069a597b9c9c890e3 SHA512 dbaa2e96035283e55c7a3c940255d9cc81d98961f59a10586cd666525a0fddf0e3ada01fd79133a278159f47c344bce70bcc4ad1b5df5c853273941b744357e4
diff --git a/net-dns/c-ares/c-ares-1.27.0.ebuild b/net-dns/c-ares/c-ares-1.27.0.ebuild
new file mode 100644
index 000000000000..f066b76c4ef8
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.27.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/danielstenberg.asc
+inherit edo multilib-minimal verify-sig
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="https://c-ares.org/"
+SRC_URI="
+ https://c-ares.org/download/${P}.tar.gz
+ verify-sig? ( https://c-ares.org/download/${P}.tar.gz.asc )
+"
+
+# ISC for lib/{bitncmp.c,inet_ntop.c,inet_net_pton.c} (bug #912405)
+LICENSE="MIT ISC"
+# Subslot = SONAME of libcares.so.2
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-cpp/gtest )
+ verify-sig? ( sec-keys/openpgp-keys-danielstenberg )
+"
+
+DOCS=( AUTHORS CHANGES NEWS README.md RELEASE-NOTES.md TODO )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ares_build.h
+)
+
+A__QA_CONFIG_IMPL_DECL_SKIP=(
+ # Checking for obsolete headers
+ malloc
+ calloc
+ free
+
+ # Non-existent on Linux
+ closesocket
+ CloseSocket
+ ioctlsocket
+ bitncmp
+ ConvertInterfaceIndexToLuid
+ ConvertInterfaceLuidToNameA
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-symbol-hiding
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ )
+
+ # Needed for running unit tests only
+ # Violates sandbox and tests pass fine without
+ export ax_cv_uts_namespace=no
+ export ax_cv_user_namespace=no
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd "${BUILD_DIR}"/test || die
+
+ # We're skipping the "real" network tests with the filter
+ # see https://github.com/c-ares/c-ares/tree/main/test
+ local network_tests=(
+ # Most live tests have Live in the name
+ *Live*
+ # These don't but are still in ares-test-live.cc => live
+ *GetTCPSock*
+ *TimeoutValue*
+ *GetSock*
+ *GetSock_virtualized*
+ *VerifySocketFunctionCallback*
+ # Seems flaky, even run manually
+ # https://github.com/c-ares/c-ares/commit/9e542a8839f81c990bb0dff14beeaf9aa6bcc18d
+ *MockUDPMaxQueriesTest.GetHostByNameParallelLookups*
+ )
+
+ # The format for disabling test1, test2, and test3 looks like:
+ # -test1:test2:test3
+ edo ./arestest --gtest_filter=-$(echo $(IFS=:; echo "${network_tests[*]}"))
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}