summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-09-08 09:36:18 +0200
committerSam James <sam@gentoo.org>2024-09-08 09:52:42 +0100
commit73369745e0a35f1b78af0e13c8db78866fae3eca (patch)
tree7570a6edd779fabe4699fa8cdc5f9525b467dc96 /net-dns
parentmedia-gfx/imagemagick: add 6.9.13.16 (diff)
downloadgentoo-73369745e0a35f1b78af0e13c8db78866fae3eca.tar.gz
gentoo-73369745e0a35f1b78af0e13c8db78866fae3eca.tar.bz2
gentoo-73369745e0a35f1b78af0e13c8db78866fae3eca.zip
net-dns/dnsdist: build fixes for gcc-15 & boost-1.86.0
Also reported & fixed upstream. Closes: https://bugs.gentoo.org/937628 Closes: https://bugs.gentoo.org/938947 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsdist/dnsdist-1.9.6-r1.ebuild117
-rw-r--r--net-dns/dnsdist/files/1.9.6-boost-1.86.0.patch35
-rw-r--r--net-dns/dnsdist/files/1.9.6-json11-gcc15.patch19
3 files changed, 171 insertions, 0 deletions
diff --git a/net-dns/dnsdist/dnsdist-1.9.6-r1.ebuild b/net-dns/dnsdist/dnsdist-1.9.6-r1.ebuild
new file mode 100644
index 000000000000..dc311688bbfd
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.9.6-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+IUSE="bpf cdb dnscrypt dnstap doh doh3 ipcipher lmdb quic regex snmp +ssl systemd test web xdp"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnscrypt? ( ssl )
+ doh? ( ssl )
+ doh3? ( ssl quic )
+ ipcipher? ( ssl )
+ quic? ( ssl )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ bpf? ( dev-libs/libbpf:= )
+ cdb? ( dev-db/tinycdb:= )
+ dev-libs/boost:=
+ sys-libs/libcap
+ dev-libs/libedit
+ dev-libs/libsodium:=
+ dnstap? ( dev-libs/fstrm )
+ doh? ( net-libs/nghttp2:= )
+ doh3? ( net-libs/quiche:= )
+ lmdb? ( dev-db/lmdb:= )
+ quic? ( net-libs/quiche )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:0= )
+ xdp? ( net-libs/xdp-tools )
+ ${LUA_DEPS}
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/1.9.6-boost-1.86.0.patch"
+ "${FILESDIR}/1.9.6-json11-gcc15.patch"
+)
+
+src_prepare() {
+ default
+
+ # clean up duplicate file
+ rm -f README.md
+}
+
+src_configure() {
+ # bug #822855
+ append-lfs-flags
+
+ # some things can only be enabled/disabled by defines
+ ! use dnstap && append-cppflags -DDISABLE_PROTOBUF
+ ! use web && append-cppflags -DDISABLE_BUILTIN_HTML
+
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+
+ local myeconfargs=(
+ --sysconfdir=/etc/dnsdist
+ --with-lua="${ELUA}"
+ --without-h2o
+ --enable-tls-providers
+ --without-gnutls
+ $(use_with bpf ebpf)
+ $(use_with cdb cdb)
+ $(use_enable doh dns-over-https)
+ $(use_enable doh3 dns-over-http3)
+ $(use_enable dnscrypt)
+ $(use_enable dnstap)
+ $(use_enable ipcipher)
+ $(use_with lmdb )
+ $(use_enable quic dns-over-quic)
+ $(use_with regex re2)
+ $(use_with snmp net-snmp)
+ $(use_enable ssl dns-over-tls)
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ $(use_with xdp xsk)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}
diff --git a/net-dns/dnsdist/files/1.9.6-boost-1.86.0.patch b/net-dns/dnsdist/files/1.9.6-boost-1.86.0.patch
new file mode 100644
index 000000000000..bf9d23984bba
--- /dev/null
+++ b/net-dns/dnsdist/files/1.9.6-boost-1.86.0.patch
@@ -0,0 +1,35 @@
+
+Fix compilation with boost-1.86.
+Patch path prefix adapted for dnsdist.
+
+From: https://github.com/PowerDNS/pdns/commit/eed56000b1d68ac083b8e8bea4ff0ea30a1579c4
+
+From eed56000b1d68ac083b8e8bea4ff0ea30a1579c4 Mon Sep 17 00:00:00 2001
+From: Michael Cho <michael@michaelcho.dev>
+Date: Thu, 15 Aug 2024 22:49:17 -0400
+Subject: [PATCH] Fix build with boost 1.86.0
+
+Boost 1.86.0 changes seem to no longer indirectly include header which
+causes build to fail with:
+```
+uuid-utils.cc:38:58:
+error: 'random' is not a class, namespace, or enumeration
+```
+
+boost/random/mersenne_twister.hpp has been available since Boost 1.21.2
+---
+ pdns/uuid-utils.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pdns/uuid-utils.cc b/pdns/uuid-utils.cc
+index c59e0a0d0daa..301daff0bb1e 100644
+--- a/uuid-utils.cc
++++ b/uuid-utils.cc
+@@ -30,6 +30,7 @@
+ #endif /* BOOST_PENDING_INTEGER_LOG2_HPP */
+ #endif /* BOOST_VERSION */
+
++#include <boost/random/mersenne_twister.hpp>
+ #include <boost/uuid/uuid_generators.hpp>
+
+ // The default of:
diff --git a/net-dns/dnsdist/files/1.9.6-json11-gcc15.patch b/net-dns/dnsdist/files/1.9.6-json11-gcc15.patch
new file mode 100644
index 000000000000..9aac470625f6
--- /dev/null
+++ b/net-dns/dnsdist/files/1.9.6-json11-gcc15.patch
@@ -0,0 +1,19 @@
+
+Fix compilation with gcc-15
+
+Bug: https://bugs.gentoo.org/937628
+Bug: https://github.com/PowerDNS/pdns/issues/14549
+
+Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com>
+
+diff -rup dnsdist-1.9.6/ext/json11/json11.cpp dnsdist-1.9.6-gcc15/ext/json11/json11.cpp
+--- dnsdist-1.9.6/ext/json11/json11.cpp 2024-07-15 11:46:15.000000000 +0200
++++ dnsdist-1.9.6-gcc15/ext/json11/json11.cpp 2024-08-09 18:03:51.090140981 +0200
+@@ -22,6 +22,7 @@
+ #include "json11.hpp"
+ #include <cassert>
+ #include <cmath>
++#include <cstdint>
+ #include <cstdlib>
+ #include <cstdio>
+ #include <limits>