summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-09 22:03:13 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-09 22:11:47 +0200
commit5940272d8a0f4e0ac6d540baf3c9ac10548e3e23 (patch)
treee977df0c48a49ec0e03e22b62672aa4a1dc4f1b8 /net-im
parentsci-libs/gloo: add 2023.01.17 (diff)
downloadgentoo-5940272d8a0f4e0ac6d540baf3c9ac10548e3e23.tar.gz
gentoo-5940272d8a0f4e0ac6d540baf3c9ac10548e3e23.tar.bz2
gentoo-5940272d8a0f4e0ac6d540baf3c9ac10548e3e23.zip
net-im/whatsie: new package, add 4.13.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/whatsie/Manifest1
-rw-r--r--net-im/whatsie/metadata.xml11
-rw-r--r--net-im/whatsie/whatsie-4.13.0.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/net-im/whatsie/Manifest b/net-im/whatsie/Manifest
new file mode 100644
index 000000000000..bf67d6ce3728
--- /dev/null
+++ b/net-im/whatsie/Manifest
@@ -0,0 +1 @@
+DIST whatsie-4.13.0.tar.gz 21145212 BLAKE2B f53549fe4975da0c5fad140568b228cb3cbdf93308cba0ddcd5aa3370ed40a84d4463e589edd1d587659b67fceb6885370b826d1746d0f31f292df1d891b3c04 SHA512 ac2b89d14c64b17a1715510754fac5b0f02528250b78fbd5dcfb782d7243ccea43d01e1dcc8507bf3056b94b3d283d9f6359451a80525c58f7889f34cc77805a
diff --git a/net-im/whatsie/metadata.xml b/net-im/whatsie/metadata.xml
new file mode 100644
index 000000000000..cbf7db3cb5c1
--- /dev/null
+++ b/net-im/whatsie/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keshavbhatt/whatsie</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/whatsie/whatsie-4.13.0.ebuild b/net-im/whatsie/whatsie-4.13.0.ebuild
new file mode 100644
index 000000000000..cecf52d1bc2d
--- /dev/null
+++ b/net-im/whatsie/whatsie-4.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Qt Based WhatsApp Client"
+HOMEPAGE="https://github.com/keshavbhatt/whatsie"
+SRC_URI="https://github.com/keshavbhatt/whatsie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+QT_MIN="5.15"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ >=dev-qt/qtcore-${QT_MIN}:5
+ >=dev-qt/qtgui-${QT_MIN}:5
+ >=dev-qt/qtnetwork-${QT_MIN}:5
+ >=dev-qt/qtpositioning-${QT_MIN}:5
+ >=dev-qt/qtwebengine-${QT_MIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QT_MIN}:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+ INSTALL_ROOT="${ED}" emake install
+}