summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-09-16 11:15:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-09-17 10:40:37 +0300
commit6bfd470b7f3a5d27cd6e164a3f387c51d938a832 (patch)
tree9fa2c2435b4033cf6d9dfc9a28df1e59b808d9ec /net-libs/gloox
parentprofiles: unmask new thunderbird-128esr (diff)
downloadgentoo-6bfd470b7f3a5d27cd6e164a3f387c51d938a832.tar.gz
gentoo-6bfd470b7f3a5d27cd6e164a3f387c51d938a832.tar.bz2
gentoo-6bfd470b7f3a5d27cd6e164a3f387c51d938a832.zip
net-libs/gloox: add examples USE flag
no revbump, as juippis suggested Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/38393 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/gloox-1.0.28.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-libs/gloox/gloox-1.0.28.ebuild b/net-libs/gloox/gloox-1.0.28.ebuild
index fe0ed1229eb2..b28ecdb63dcb 100644
--- a/net-libs/gloox/gloox-1.0.28.ebuild
+++ b/net-libs/gloox/gloox-1.0.28.ebuild
@@ -15,7 +15,7 @@ LICENSE="GPL-3"
# Check upstream changelog: https://camaya.net/gloox/changelog/
SLOT="0/18"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug gnutls idn ssl static-libs test +xhtmlim zlib"
+IUSE="debug examples gnutls idn ssl static-libs test +xhtmlim zlib"
RESTRICT="!test? ( test )"
DEPEND="
@@ -34,12 +34,12 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- --without-examples # not installed anyway so don't build them
$(usex debug "--enable-debug" '')
$(use_enable static-libs static)
$(use_enable xhtmlim)
- $(use_with idn libidn)
+ $(use_with examples)
$(use_with gnutls)
+ $(use_with idn libidn)
$(use_with ssl openssl)
$(use_with test tests)
$(use_with zlib)
@@ -50,4 +50,11 @@ src_configure() {
src_install() {
default
find "${ED}" -name "*.la" -delete || die
+
+ if use examples; then
+ # unhide the libs directory
+ mv "${S}"/src/examples/.libs "${S}"/src/examples/libs
+
+ dodoc -r src/examples/
+ fi
}