summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 13:05:56 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 13:16:33 +0300
commit551b749961d032b04e6b9e50bf297b3b1b3fbbfd (patch)
treebed822f15f3c51ddefeae98a04cbdf47f481064e /net-libs/ldns
parentnet-libs/gsoap: remove libressl support (diff)
downloadgentoo-551b749961d032b04e6b9e50bf297b3b1b3fbbfd.tar.gz
gentoo-551b749961d032b04e6b9e50bf297b3b1b3fbbfd.tar.bz2
gentoo-551b749961d032b04e6b9e50bf297b3b1b3fbbfd.zip
net-libs/ldns: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-libs/ldns')
-rw-r--r--net-libs/ldns/ldns-1.7.1-r1.ebuild13
-rw-r--r--net-libs/ldns/ldns-1.7.1-r2.ebuild15
2 files changed, 12 insertions, 16 deletions
diff --git a/net-libs/ldns/ldns-1.7.1-r1.ebuild b/net-libs/ldns/ldns-1.7.1-r1.ebuild
index 78a9e8a8dfe1..95e2628a1d8e 100644
--- a/net-libs/ldns/ldns-1.7.1-r1.ebuild
+++ b/net-libs/ldns/ldns-1.7.1-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa ed25519 ed448 gost libressl python static-libs vim-syntax"
+IUSE="+dane doc +ecdsa ed25519 ed448 gost python static-libs vim-syntax"
# configure will die if ecdsa is enabled and ssl is not
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -20,16 +20,15 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
python? ( ${PYTHON_DEPS} )
ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}]
)
ed25519? (
- !libressl? ( >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}]
)
ed448? (
- !libressl? ( >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}]
)
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
@@ -48,7 +47,7 @@ pkg_setup() {
multilib_src_configure() {
# >=openssl-1.1.0 required for dane-ta
- if has_version "<dev-libs/openssl-1.1.0" || use libressl; then
+ if has_version "<dev-libs/openssl-1.1.0"; then
local dane_ta_usage="--disable-dane-ta-usage"
else
local dane_ta_usage=""
diff --git a/net-libs/ldns/ldns-1.7.1-r2.ebuild b/net-libs/ldns/ldns-1.7.1-r2.ebuild
index 9e872b955a93..ee8acea2dae4 100644
--- a/net-libs/ldns/ldns-1.7.1-r2.ebuild
+++ b/net-libs/ldns/ldns-1.7.1-r2.ebuild
@@ -12,28 +12,25 @@ SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa ed25519 ed448 gost libressl python static-libs vim-syntax"
+IUSE="+dane doc +ecdsa ed25519 ed448 gost python static-libs vim-syntax"
# configure will die if ecdsa is enabled and ssl is not
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
- ed25519? ( !libressl )
- ed448? ( !libressl )
"
RDEPEND="
python? ( ${PYTHON_DEPS} )
ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}]
)
ed25519? (
- !libressl? ( >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.0:0=[-bindist,${MULTILIB_USEDEP}]
)
ed448? (
- !libressl? ( >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.1.1:0=[-bindist,${MULTILIB_USEDEP}]
)
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}
python? ( dev-lang/swig )
@@ -52,7 +49,7 @@ pkg_setup() {
multilib_src_configure() {
# >=openssl-1.1.0 required for dane-ta
- if has_version "<dev-libs/openssl-1.1.0" || use libressl; then
+ if has_version "<dev-libs/openssl-1.1.0"; then
local dane_ta_usage="--disable-dane-ta-usage"
else
local dane_ta_usage=""