summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libinfinity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libinfinity')
-rw-r--r--net-libs/libinfinity/Manifest1
-rw-r--r--net-libs/libinfinity/files/infinoted.confd12
-rw-r--r--net-libs/libinfinity/files/infinoted.initd28
-rw-r--r--net-libs/libinfinity/libinfinity-0.5.4.ebuild70
-rw-r--r--net-libs/libinfinity/metadata.xml14
5 files changed, 125 insertions, 0 deletions
diff --git a/net-libs/libinfinity/Manifest b/net-libs/libinfinity/Manifest
new file mode 100644
index 000000000000..3aebbc490394
--- /dev/null
+++ b/net-libs/libinfinity/Manifest
@@ -0,0 +1 @@
+DIST libinfinity-0.5.4.tar.gz 1452217 SHA256 04004fc1097e0e45945180f844b1f7cef62db18390d752c8abca78253192f6c4 SHA512 3586865b0cbae7a7397fc819613eb336901daf9d99cc7bcab72e8b38ee10aa1df8b737872c83ff409b29eae8e3667ea81565d624e8357d7506f138677536b4ae WHIRLPOOL 20c5baf2b69f4b5d0a4846510e999f4f477ae3afe4df39e0e45f65c3c0d092ed52b21ff59fc712b265a8614286c1fce07510d3850b20dea6a32257d06407c373
diff --git a/net-libs/libinfinity/files/infinoted.confd b/net-libs/libinfinity/files/infinoted.confd
new file mode 100644
index 000000000000..81e62a4d9515
--- /dev/null
+++ b/net-libs/libinfinity/files/infinoted.confd
@@ -0,0 +1,12 @@
+# Config file for /etc/init.d/infinoted for Gentoo Linux
+
+USER="infinote"
+GROUP="infinote"
+UMASK="007"
+
+PIDFILE="/var/run/infinoted.pid"
+
+# Please read `infinoted --help` for other options.
+# This is a fast setup for local networks only (maybe not even those),
+# make sure you use appropriate security on untrusted networks.
+OPTIONS="--root-directory=/var/lib/infinote --security-policy=no-tls"
diff --git a/net-libs/libinfinity/files/infinoted.initd b/net-libs/libinfinity/files/infinoted.initd
new file mode 100644
index 000000000000..b8f3f1f849f2
--- /dev/null
+++ b/net-libs/libinfinity/files/infinoted.initd
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting infinoted"
+ start-stop-daemon \
+ --start --quiet --background --make-pidfile \
+ --pidfile /var/run/infinoted.pid \
+ --exec /usr/bin/infinoted \
+ --user ${USER} --group ${GROUP} --umask 007 \
+ -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping infinoted"
+ start-stop-daemon \
+ --stop --quiet \
+ --pidfile /var/run/infinoted.pid
+ eend $?
+}
diff --git a/net-libs/libinfinity/libinfinity-0.5.4.ebuild b/net-libs/libinfinity/libinfinity-0.5.4.ebuild
new file mode 100644
index 000000000000..ec6cbbf0a489
--- /dev/null
+++ b/net-libs/libinfinity/libinfinity-0.5.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils eutils versionator user
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="An implementation of the Infinote protocol written in GObject-based C"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi doc gtk server static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/gnutls
+ sys-libs/pam
+ virtual/gsasl
+ avahi? ( net-dns/avahi )
+ gtk? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )"
+
+DOCS=(AUTHORS NEWS README TODO)
+
+pkg_setup() {
+ if use server ; then
+ enewgroup infinote 100
+ enewuser infinote 100 /bin/bash /var/lib/infinote infinote
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc gtk-doc)
+ $(use_with gtk inftextgtk)
+ $(use_with gtk infgtk)
+ $(use_with gtk gtk3)
+ $(use_with server infinoted)
+ $(use_with avahi)
+ $(use_with avahi libdaemon)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use server ; then
+ newinitd "${FILESDIR}/infinoted.initd" infinoted
+ newconfd "${FILESDIR}/infinoted.confd" infinoted
+
+ keepdir /var/lib/infinote
+ fowners infinote:infinote /var/lib/infinote
+ fperms 770 /var/lib/infinote
+
+ dosym /usr/bin/infinoted-${MY_PV} /usr/bin/infinoted
+
+ elog "Add local users who should have local access to the documents"
+ elog "created by infinoted to the infinote group."
+ elog "The documents are saved in /var/lib/infinote per default."
+ fi
+}
diff --git a/net-libs/libinfinity/metadata.xml b/net-libs/libinfinity/metadata.xml
new file mode 100644
index 000000000000..e3f8eb8c5df2
--- /dev/null
+++ b/net-libs/libinfinity/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <use>
+ <flag name='server'>
+ Build and install the server binary including init.d/conf.d-scripts.
+ Needed if you want to host an infinote server for gobby.
+ </flag>
+ </use>
+</pkgmetadata>