summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2024-03-27 12:08:42 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-04-29 11:41:05 +0300
commit750f8b3372037571b37f5980a6ae027a86e6aad9 (patch)
tree6f0054e38490cb4c9405a591969fca08fb17f70e /net-libs/libmicrohttpd
parentnet-im/signal-cli-bin: fix start script (diff)
downloadgentoo-750f8b3372037571b37f5980a6ae027a86e6aad9.tar.gz
gentoo-750f8b3372037571b37f5980a6ae027a86e6aad9.tar.bz2
gentoo-750f8b3372037571b37f5980a6ae027a86e6aad9.zip
net-libs/libmicrohttpd: upstream version 1.0.1
Closes: https://bugs.gentoo.org/927919 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/35944 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 43a0ae433262..287f05186784 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,2 +1,3 @@
DIST libmicrohttpd-0.9.76.tar.gz 2199858 BLAKE2B 2c2de77d731ff130bb1491733b91e9e0b0c68bc30ea1a826f7f1d97aaf83fa7f6bec3c219f81c5293de72595b26d1e6eb66cdd4bfe3b16bd37a10e3acd3c6446 SHA512 9ff8a837892142376eaeaf50c0b0dba76697d0ff44b908434cba8db4324c57dfb8bbcc1a922b97d825891ac10f50693dee9388531856e0fa81fa2cfeac538581
DIST libmicrohttpd-0.9.77.tar.gz 1896679 BLAKE2B 09a07c7da77d6072e5aa0fb121aedffb66b6cfdb2da30d1809583469282365832beb935417e779ddb31876949358d25c10bf79616079393503ca5860d88ac052 SHA512 001025c023dd94c4a0cf017ed575e65a577b5ce595e7e450346bfb75def77eaa8a4cfbeffb9f4b912e34165c2cfca147c02c895e067a4f6c5a321a12035758a5
+DIST libmicrohttpd-1.0.1.tar.gz 2239593 BLAKE2B a29e49c719fc544ae72224d81cba7b7ef914f2641efe4b90d580d2212f2c3357a6d70499c43a6f50d14f4ec9d3102da8de899fe0420bf6660eb413080d89b7f7 SHA512 c99b8b93cae5feee8debcc5667ee3ff043412a84b30696fe852e6c138f3c890bb43c8fcd7199f1d2f809d522fef159e83b607c743d6cf3401a57050fbdf9b5c1
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild
new file mode 100644
index 000000000000..bf51ab887652
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-1.0.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit linux-info multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="|| ( LGPL-2.1+ !ssl? ( GPL-2+-with-eCos-exception-2 ) )"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="debug +epoll +eventfd ssl static-libs test +thread-names verify-sig"
+REQUIRED_USE="epoll? ( kernel_linux )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( >net-libs/gnutls-2.12.20:=[${MULTILIB_USEDEP}] )"
+# libcurl and the curl binary are used during tests on CHOST
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl[ssl?] )"
+BDEPEND="ssl? ( virtual/pkgconfig )"
+
+DOCS=( AUTHORS NEWS COPYING README ChangeLog )
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK=""
+ use epoll && CONFIG_CHECK+=" ~EPOLL"
+ ERROR_EPOLL="EPOLL is not enabled in kernel, but enabled in libmicrohttpd."
+ ERROR_EPOLL+=" libmicrohttpd will fail to start with 'automatic' configuration."
+ use eventfd && CONFIG_CHECK+=" ~EVENTFD"
+ ERROR_EVENTFD="EVENTFD is not enabled in kernel, but enabled in libmicrohttpd."
+ ERROR_EVENTFD+=" libmicrohttpd will not work."
+ check_extra_config
+ fi
+}
+
+multilib_src_configure() {
+ local itc_type
+ if use eventfd; then
+ itc_type="eventfd"
+ else
+ itc_type="pipe"
+ fi
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --enable-bauth \
+ --enable-dauth \
+ --enable-messages \
+ --enable-postprocessor \
+ --enable-httpupgrade \
+ --disable-examples \
+ --disable-tools \
+ --disable-experimental \
+ --disable-heavy-tests \
+ --enable-itc=${itc_type} \
+ $(use_enable debug asserts) \
+ $(use_enable thread-names) \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https)
+}
+
+multilib_src_install_all() {
+ default
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}