summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-02 21:25:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-02 20:39:05 +0100
commit1688b4ccd515d386cc5fbc0c817901ee6f57d487 (patch)
tree0729b7aa023475451ef521ffa73e09b24cbfca16 /net-libs/libquotient
parentapp-text/lowdown: add 1.3.0 (diff)
downloadgentoo-1688b4ccd515d386cc5fbc0c817901ee6f57d487.tar.gz
gentoo-1688b4ccd515d386cc5fbc0c817901ee6f57d487.tar.bz2
gentoo-1688b4ccd515d386cc5fbc0c817901ee6f57d487.zip
net-libs/libquotient: add 0.9.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.9.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index a0e501e161b9..4be4453e4434 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1,2 +1,3 @@
DIST libquotient-0.8.2.tar.gz 744095 BLAKE2B c33016e4eda22e0a363f06ab4545d17010519b8d778566c1bae29e4c7d6563280f4ce3c1235f7d75f55ce4a8971ef5ce23e45f1d3a0edc043e23857d805a824f SHA512 3d971439f8a89609930ca1648f6cf1bdb59f3ad492af1a15a7f8a13d06c81bd5bfffa1dd732ef5156fab8a9ea2ba3e98376bf76511db17bdeee17641a772b762
DIST libquotient-0.9.0.tar.gz 771510 BLAKE2B 27e3ac3f8b5cad43a722b805c523bbe6663205fad2a4dfe3a7a1eead67d0a909ba4b6d25398bdde7d005d8935f1dd0c40e00f1038f7604b7f49059a121cc9d9b SHA512 7be9c25f4232ea0640f974db95ed67f5f91caaaa883a81fd14b732df4a0cdc8af0569110d641a246d7c8b021726d3086f75d1df836d3a6e5dff3b82b28a2f50e
+DIST libquotient-0.9.1.tar.gz 772882 BLAKE2B f43da0833baa1242f29fb7ed1dd1065b673497d8e2d8358b60d67da0fef8f382ac3fdda8cdc9ed0ac67b5cd423527ef418d0a574fd30e46fe9337214509b1dc2 SHA512 f998b187a1168381c7868400fec73f68ab95af29d1d648921a507fac8782f8c69fd8aab7916466ad9d6b85edadf5168659d7b78a876daa30798891d84afcfa5a
diff --git a/net-libs/libquotient/libquotient-0.9.1.ebuild b/net-libs/libquotient/libquotient-0.9.1.ebuild
new file mode 100644
index 000000000000..92551379487e
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/${PV}" # FIXME: check soname on next version bump
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ >=dev-libs/qtkeychain-0.14.2:=[qt6(+)]
+ >=dev-qt/qtbase-6.4:6=[gui,network,sql,ssl]
+ >=dev-qt/qtmultimedia-6.4:6
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-6.4:6[concurrent] )
+"
+
+# downstream patch
+PATCHES=( "${FILESDIR}"/${PN}-0.8.0-no-android.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}