summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-18 11:31:48 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-18 11:43:18 +0100
commit012a41831f3bb7e86b5e19ae9e9b107e4c5dfd66 (patch)
treed1df5b776a1e290768d5b9cd4da11f8e7cd3073e /net-libs/libtrace/libtrace-4.0.2.ebuild
parentnet-misc/openssh: stable 7.5_p1-r3 for sparc, bug #633428 (thanks to Rolf Eik... (diff)
downloadgentoo-012a41831f3bb7e86b5e19ae9e9b107e4c5dfd66.tar.gz
gentoo-012a41831f3bb7e86b5e19ae9e9b107e4c5dfd66.tar.bz2
gentoo-012a41831f3bb7e86b5e19ae9e9b107e4c5dfd66.zip
net-libs/libtrace: Version bump.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-libs/libtrace/libtrace-4.0.2.ebuild')
-rw-r--r--net-libs/libtrace/libtrace-4.0.2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/libtrace/libtrace-4.0.2.ebuild b/net-libs/libtrace/libtrace-4.0.2.ebuild
new file mode 100644
index 000000000000..bb592018d475
--- /dev/null
+++ b/net-libs/libtrace/libtrace-4.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A library and tools for trace processing"
+HOMEPAGE="http://research.wand.net.nz/software/libtrace.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ncurses numa static-libs"
+
+RDEPEND="
+ >=net-libs/libpcap-0.8
+ dev-libs/openssl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ net-libs/wandio
+ numa? ( sys-process/numactl )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.20-autoconf-1.13.patch
+ "${FILESDIR}"/${PN}-3.0.20-tinfo.patch
+ "${FILESDIR}"/${PN}-4.0.0-no-examples.patch
+ "${FILESDIR}"/${PN}-4.0.0-with-numa.patch
+)
+S=${WORKDIR}/${P/_beta/}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ncurses) \
+ $(use_with numa) \
+ --with-man
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r docs/doxygen/html
+
+ prune_libtool_files --modules
+}