summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2016-09-15 20:50:47 +0100
committerIan Whyman <thev00d00@gentoo.org>2016-09-15 20:51:16 +0100
commit84d8f21cc2ca94d4f4a3146302726bd1c8fd3f47 (patch)
tree7ff7fd24afaace2048fcea22913a723ab98bedf2 /net-libs/libupnp/libupnp-1.6.20.ebuild
parentdev-libs/leatherman: bup (diff)
downloadgentoo-84d8f21cc2ca94d4f4a3146302726bd1c8fd3f47.tar.gz
gentoo-84d8f21cc2ca94d4f4a3146302726bd1c8fd3f47.tar.bz2
gentoo-84d8f21cc2ca94d4f4a3146302726bd1c8fd3f47.zip
net-libs/libupnp: Bump to 1.6.20, fix #546616
Diffstat (limited to 'net-libs/libupnp/libupnp-1.6.20.ebuild')
-rw-r--r--net-libs/libupnp/libupnp-1.6.20.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libupnp/libupnp-1.6.20.ebuild b/net-libs/libupnp/libupnp-1.6.20.ebuild
new file mode 100644
index 000000000000..83c50e86c2f0
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.6.20.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="debug doc ipv6 static-libs"
+
+DOCS="NEWS README ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-docs-install.patch
+ "${FILESDIR}"/CVE-2016-6255.patch
+)
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable static-libs static) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+ dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}
+ use static-libs || prune_libtool_files
+}