summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-22 21:37:09 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-25 22:42:40 +0200
commit83f1ca506ece6040cfc937738bdbc928ba909372 (patch)
tree6a3e0c63e0d59e27f22340735ed49cf121087bc8 /net-libs/signond
parentkde-apps/kdenetwork-meta: Add kde-misc/kio-gdrive revdeps (diff)
downloadgentoo-83f1ca506ece6040cfc937738bdbc928ba909372.tar.gz
gentoo-83f1ca506ece6040cfc937738bdbc928ba909372.tar.bz2
gentoo-83f1ca506ece6040cfc937738bdbc928ba909372.zip
net-libs/signond: Add pkg_postinst warning
Closes: https://bugs.gentoo.org/642420 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/signond')
-rw-r--r--net-libs/signond/signond-8.61-r100.ebuild8
-rw-r--r--net-libs/signond/signond-8.61.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/net-libs/signond/signond-8.61-r100.ebuild b/net-libs/signond/signond-8.61-r100.ebuild
index 3a6494c050a6..1c3cc37a6396 100644
--- a/net-libs/signond/signond-8.61-r100.ebuild
+++ b/net-libs/signond/signond-8.61-r100.ebuild
@@ -143,3 +143,11 @@ src_install() {
multibuild_foreach_variant my_src_install
}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] && \
+ ! has_version "kde-apps/signon-kwallet-extension:*"; then
+ ewarn "Without kde-apps/signon-kwallet-extension installed, passwords"
+ ewarn "will be saved in plaintext!"
+ fi
+}
diff --git a/net-libs/signond/signond-8.61.ebuild b/net-libs/signond/signond-8.61.ebuild
index e1079e2ed2f8..6f21b1bec048 100644
--- a/net-libs/signond/signond-8.61.ebuild
+++ b/net-libs/signond/signond-8.61.ebuild
@@ -70,3 +70,11 @@ src_configure() {
src_install() {
emake INSTALL_ROOT="${D}" install
}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] && \
+ ! has_version "kde-apps/signon-kwallet-extension:*"; then
+ ewarn "Without kde-apps/signon-kwallet-extension installed, passwords"
+ ewarn "will be saved in plaintext!"
+ fi
+}