summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-01-19 03:28:03 +0200
committerIonen Wolkens <ionen@gentoo.org>2022-01-21 19:32:37 -0500
commita6ea79ad79a913d8fe9923228d4549a890c1ba97 (patch)
treecf7cfe2cd9e34c0fdc3429ef4cbc5a31f6c5e48a /net-libs/toxext/toxext-0.0.3.ebuild
parentmedia-video/obs-studio: switch myself to proxy-maint in metadata (diff)
downloadgentoo-a6ea79ad79a913d8fe9923228d4549a890c1ba97.tar.gz
gentoo-a6ea79ad79a913d8fe9923228d4549a890c1ba97.tar.bz2
gentoo-a6ea79ad79a913d8fe9923228d4549a890c1ba97.zip
net-libs/toxext: add version 0.0.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-libs/toxext/toxext-0.0.3.ebuild')
-rw-r--r--net-libs/toxext/toxext-0.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/toxext/toxext-0.0.3.ebuild b/net-libs/toxext/toxext-0.0.3.ebuild
new file mode 100644
index 000000000000..d0e36bc54a35
--- /dev/null
+++ b/net-libs/toxext/toxext-0.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Extension Library for Tox"
+HOMEPAGE="https://github.com/toxext/toxext"
+SRC_URI="https://github.com/toxext/toxext/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-libs/tox:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i 's/-Werror//' CMakeLists.txt || die
+}