summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-04-25 03:02:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-25 03:02:34 +0200
commit1fcd13fa536075ac1239a6662efc09dcd566b135 (patch)
tree0a95a6cd07637ff63ebd4755d6e9ed481c3cddbb /net-libs
parentnet-ftp/pure-ftpd: Bump to version 1.0.46 (diff)
downloadgentoo-1fcd13fa536075ac1239a6662efc09dcd566b135.tar.gz
gentoo-1fcd13fa536075ac1239a6662efc09dcd566b135.tar.bz2
gentoo-1fcd13fa536075ac1239a6662efc09dcd566b135.zip
net-libs/nghttp2: Bump to version 1.22.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.22.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 7cf59175d7f9..9cedd7c8a1ff 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -4,3 +4,4 @@ DIST nghttp2-1.19.0.tar.gz 2159530 SHA256 b67946ad211aa3f7c91f4d866f47b056e821da
DIST nghttp2-1.20.0.tar.gz 2173657 SHA256 bdbc4a9ca12fe34cb0360d5e6d2e3a8dfbe48ff9454252aaa44cfcab614bba33 SHA512 62627c1a203ad805888c45985fcd54c0227378ea51649558aef1f02665b4d5f1ef40cb5cc7b3ba67675c883abf241f6072f06aca7fea7fea385b696e4528840e WHIRLPOOL 114a700db023a7f4b413af2c16f67334cf107c0053e9e20121a8fe26ffa67f85c20a594aa67f0c477680174efac1a7acd04934ff7220451d0b5c893557fb6af7
DIST nghttp2-1.21.0.tar.gz 2170365 SHA256 0c4b66741b97b46dd37ffcf354d3e40128cca9033f6d60e66c5bd3b99e556ff6 SHA512 1d4ab540588df2e241b5b807dcb695aaa5349a4d3d99475febb6db181ced9995092f37ff1e01e702b9921d64ad8bb11d5bf335f1c129443372c457272aa834f7 WHIRLPOOL 366a41e14e913eb901bdb2b91e8f01463faae70b2dd6835dc44f95e4002d12cb3a71c8a795fe1c5380b7b781f57fbcd9466a8709ff736e3d6c61b354c4e2fa36
DIST nghttp2-1.21.1.tar.gz 2167306 SHA256 4d575f872fe91bf45c424d93b5b566728d6250b5c7af4ffd7753c52cbac9e609 SHA512 d5bee6c76aee337ecd48563ad1530f15da52496a13cce97b986632258f03173d0c2f1b181e8f90765c6810e41c08f672a8bc81125c2762d186d0da388fb54a92 WHIRLPOOL 1ac14456c0ee520257dc475e76182919fe2abd3bfae39adc60d05ecc5efb4d49abcb60dae92f9cc73eb401b715a794eb1b86be4082dbd1955c2c6d45ae2a4c8f
+DIST nghttp2-1.22.0.tar.gz 2176030 SHA256 f4b5f3afdad69ea2b2542bc998128e2d02a33c40e53e60fd814788518b56b13f SHA512 e439e4b2b06a8bfef80d1d963d70612b13eaf613e2be78537971e867fd82f222e5457533dee540c5239e00ee78ca8c1efbaccf8cdeacd1c46b58f89ee5ecf327 WHIRLPOOL 4d493e5ef129432ce17110279178dda9d0cf1aaa4df82a05084ae052d3fe21342aadcac46fb9c52434f6e3325c99d2750b57a47d7c11292eda2b09f15669d927
diff --git a/net-libs/nghttp2/nghttp2-1.22.0.ebuild b/net-libs/nghttp2/nghttp2-1.22.0.ebuild
new file mode 100644
index 000000000000..3ec4b994bb7c
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.22.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}