summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-07-18 11:35:52 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-07-18 11:38:22 -0500
commit305e66472660ee50117267b499f23d3883340deb (patch)
treeb42bfb1a55ce5f9e2d1e9697706083aa40445f62 /net-libs
parentdev-lang/python: Bump to 3.13.0_beta4 (diff)
downloadgentoo-305e66472660ee50117267b499f23d3883340deb.tar.gz
gentoo-305e66472660ee50117267b499f23d3883340deb.tar.bz2
gentoo-305e66472660ee50117267b499f23d3883340deb.zip
net-libs/nodejs: use get_NINJAOPTS
Before this change, -l or --load-average was not respected by the upstream build system. Closes: https://bugs.gentoo.org/935806 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-20.15.1.ebuild3
-rw-r--r--net-libs/nodejs/nodejs-22.4.1.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/net-libs/nodejs/nodejs-20.15.1.ebuild b/net-libs/nodejs/nodejs-20.15.1.ebuild
index 8fdfeb48ebd2..c64c7c0937b6 100644
--- a/net-libs/nodejs/nodejs-20.15.1.ebuild
+++ b/net-libs/nodejs/nodejs-20.15.1.ebuild
@@ -7,7 +7,7 @@ CONFIG_CHECK="~ADVISE_SYSCALLS"
PYTHON_COMPAT=( python3_{9..12} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 check-reqs flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -169,6 +169,7 @@ src_configure() {
}
src_compile() {
+ export NINJA_ARGS=$(get_NINJAOPTS)
emake -Onone
}
diff --git a/net-libs/nodejs/nodejs-22.4.1.ebuild b/net-libs/nodejs/nodejs-22.4.1.ebuild
index 3b8cd150293e..9ea8cdbd10f4 100644
--- a/net-libs/nodejs/nodejs-22.4.1.ebuild
+++ b/net-libs/nodejs/nodejs-22.4.1.ebuild
@@ -7,7 +7,7 @@ CONFIG_CHECK="~ADVISE_SYSCALLS"
PYTHON_COMPAT=( python3_{9..12} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 check-reqs flag-o-matic linux-info pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -182,6 +182,7 @@ src_configure() {
}
src_compile() {
+ export NINJA_ARGS=" $(get_NINJAOPTS)"
emake -Onone
}