summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-19 15:41:27 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-19 15:43:53 -0500
commit789ffad64bc72115c0252d442e367fe7c9177bb1 (patch)
treedbd79ce745c6c441abab4cbdbf81971d75a9d4ff /net-libs
parentnet-libs/nghttp3: add USE=static-libs (diff)
downloadgentoo-789ffad64bc72115c0252d442e367fe7c9177bb1.tar.gz
gentoo-789ffad64bc72115c0252d442e367fe7c9177bb1.tar.bz2
gentoo-789ffad64bc72115c0252d442e367fe7c9177bb1.zip
net-libs/nghttp3: drop 0_pre20190912, 0.8.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.8.0.ebuild39
-rw-r--r--net-libs/nghttp3/nghttp3-0_pre20190912.ebuild41
3 files changed, 0 insertions, 81 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 00ab146d630c..44d9b41aa074 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,2 +1 @@
DIST nghttp3-0.8.0.tar.xz 365072 BLAKE2B 132332f785f015a5e62e751ad6fe6d1dae49911837ef26cb24453245ca2cd5a80c92092db4b712f1fb515caa900ac190c2fa586fbf7314df9e60928595791679 SHA512 dab545aff7f85ee10c0f43985cb7f937e33a793c4bb0ca8e7878652f8d0b2500497cdd435256f401bf35a0c7af21aec08cd821beddff3e96b4810efb4c798591
-DIST nghttp3-0_pre20190912.tar.gz 155172 BLAKE2B fabd472e429222502288b7a4030b4aa51f8a1b609590d63b51ab3f918b8cdb462b766a40911986b3f72f2f1b0debee1f0ebdf8802991bf4fc5d4a6d14297bdcc SHA512 89c7b40843bde9d2c2ab24211794b6ae0e1fa15413e92dcf2238b876552f29bb2f0db724d9a205c2a1c98f25a14ef570c9e53df52fb519230b6f78dcc04d2117
diff --git a/net-libs/nghttp3/nghttp3-0.8.0.ebuild b/net-libs/nghttp3/nghttp3-0.8.0.ebuild
deleted file mode 100644
index 3685e3ee33ca..000000000000
--- a/net-libs/nghttp3/nghttp3-0.8.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}
diff --git a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild b/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
deleted file mode 100644
index 13c321f3927c..000000000000
--- a/net-libs/nghttp3/nghttp3-0_pre20190912.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- GIT_COMMIT="51379a041174ad953dc6ad437712f3b279f81919"
- SRC_URI="https://github.com/ngtcp2/nghttp3/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${GIT_COMMIT}"
- KEYWORDS="~amd64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}