summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2022-01-11 01:08:01 +0200
committerMart Raudsepp <leio@gentoo.org>2022-01-11 01:48:17 +0200
commit84c103ce7c671f0172e84bfc5b1e7b7b74335116 (patch)
tree683a20b0da23adeddc8a625c0c12a86f8e03239b /net-libs
parentsci-libs/gdal: fix build with Poppler 22.01.0 (build with C++ 17) (diff)
downloadgentoo-84c103ce7c671f0172e84bfc5b1e7b7b74335116.tar.gz
gentoo-84c103ce7c671f0172e84bfc5b1e7b7b74335116.tar.bz2
gentoo-84c103ce7c671f0172e84bfc5b1e7b7b74335116.zip
net-libs/webkit-gtk: fix USE=jumbo-build on some machines
Thanks-to: gen2dev Closes: https://bugs.gentoo.org/830638 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/files/2.34.3-jumbo-fix.patch70
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild1
2 files changed, 71 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/2.34.3-jumbo-fix.patch b/net-libs/webkit-gtk/files/2.34.3-jumbo-fix.patch
new file mode 100644
index 000000000000..97c5c0c8e4b6
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.34.3-jumbo-fix.patch
@@ -0,0 +1,70 @@
+From b60c2e4d1770660280d97cae9e82f3040ab97229 Mon Sep 17 00:00:00 2001
+From: "philn@webkit.org"
+ <philn@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Sat, 11 Sep 2021 11:34:42 +0000
+Subject: [PATCH] [GLIB] MediaSession is not enabled
+ https://bugs.webkit.org/show_bug.cgi?id=217991 <rdar://problem/70740119>
+
+leio: Extracted to include only the side-effect of fixing unity builds on
+some machine configurations.
+Thanks-To gen2dev
+---
+ Source/WebCore/platform/PlatformScreen.h | 6 ++++++
+ Source/WebCore/platform/graphics/ImageFrame.h | 6 ++++++
+ Source/WebCore/platform/graphics/ImageOrientation.h | 6 ++++++
+ 3 files changed, 18 insertions(+)
+
+diff --git a/Source/WebCore/platform/PlatformScreen.h b/Source/WebCore/platform/PlatformScreen.h
+index d3f12a6538b8..d47d193e8bee 100644
+--- a/Source/WebCore/platform/PlatformScreen.h
++++ b/Source/WebCore/platform/PlatformScreen.h
+@@ -48,6 +48,12 @@ OBJC_CLASS UIScreen;
+ typedef struct CGColorSpace *CGColorSpaceRef;
+ #endif
+
++// X11 headers define a bunch of macros with common terms, interfering with WebCore and WTF enum values.
++// As a workaround, we explicitly undef them here.
++#if defined(None)
++#undef None
++#endif
++
+ namespace WebCore {
+
+ class DestinationColorSpace;
+diff --git a/Source/WebCore/platform/graphics/ImageFrame.h b/Source/WebCore/platform/graphics/ImageFrame.h
+index 9843aac40eb4..92e1d4486c5f 100644
+--- a/Source/WebCore/platform/graphics/ImageFrame.h
++++ b/Source/WebCore/platform/graphics/ImageFrame.h
+@@ -33,6 +33,12 @@
+ #include "NativeImage.h"
+ #include <wtf/Seconds.h>
+
++// X11 headers define a bunch of macros with common terms, interfering with WebCore and WTF enum values.
++// As a workaround, we explicitly undef them here.
++#if defined(None)
++#undef None
++#endif
++
+ namespace WebCore {
+
+ class ImageFrame {
+diff --git a/Source/WebCore/platform/graphics/ImageOrientation.h b/Source/WebCore/platform/graphics/ImageOrientation.h
+index d990a3dc555f..5de271e52352 100644
+--- a/Source/WebCore/platform/graphics/ImageOrientation.h
++++ b/Source/WebCore/platform/graphics/ImageOrientation.h
+@@ -30,6 +30,12 @@
+ #include "FloatSize.h"
+ #include <wtf/EnumTraits.h>
+
++// X11 headers define a bunch of macros with common terms, interfering with WebCore and WTF enum values.
++// As a workaround, we explicitly undef them here.
++#if defined(None)
++#undef None
++#endif
++
+ namespace WebCore {
+
+ struct ImageOrientation {
+--
+2.32.0
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
index 66ff477c7c80..aa79d69ea210 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.34.3.ebuild
@@ -159,6 +159,7 @@ pkg_setup() {
src_prepare() {
eapply "${FILESDIR}"/2.34.3-opengl-without-X-fixes.patch
eapply "${FILESDIR}"/2.34.3-non-jumbo-fix.patch
+ eapply "${FILESDIR}"/2.34.3-jumbo-fix.patch # bug 830638
cmake_src_prepare
gnome2_src_prepare
}