summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-13 21:41:45 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-26 09:27:12 +0100
commitaf55b55e2fd53718aa326c425dd5b874a70719cc (patch)
tree51ac0670e73f93d26ec4746a9cf6f33700943918 /net-libs
parentdev-java/sun-jai-bin: style update, update EAPI 7 -> 8 (diff)
downloadgentoo-af55b55e2fd53718aa326c425dd5b874a70719cc.tar.gz
gentoo-af55b55e2fd53718aa326c425dd5b874a70719cc.tar.bz2
gentoo-af55b55e2fd53718aa326c425dd5b874a70719cc.zip
net-libs/NativeThread: style update, update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/39233/commits/a8a26b135679d02d0cfc4f57050c861a5d55808f Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20190914-r2.ebuild (renamed from net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild)16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild b/net-libs/NativeThread/NativeThread-0_pre20190914-r2.ebuild
index 92146917eb6e..8b153683c6b0 100644
--- a/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
+++ b/net-libs/NativeThread/NativeThread-0_pre20190914-r2.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic java-pkg-2 toolchain-funcs
DESCRIPTION="NativeThread for priorities on linux for freenet"
HOMEPAGE="https://github.com/hyphanet/contrib/blob/master/README"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64"
-CDEPEND="
- dev-java/jna:4
+CDEPEND="dev-java/jna:4"
+DEPEND="
+ net-p2p/freenet
+ >=virtual/jdk-1.8:*
"
-DEPEND="net-p2p/freenet
- >=virtual/jdk-1.8:*"
RDEPEND=">=virtual/jre-1.8:*"
-S="${WORKDIR}"
-
PATCHES=(
"${FILESDIR}/${P}-javah.patch"
)
src_prepare() {
- default
+ default #780585
+ java-pkg-2_src_prepare
}
src_compile() {