summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-04 16:45:43 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-04 16:45:43 +0200
commitbd130f9e7c723629ba84a231b4b5b9774ca6de7b (patch)
treea8279c89a9063fac9c31eb02b89668f84f35063b /net-libs
parentapp-text/pastebinit: keyword ~riscv (diff)
downloadgentoo-bd130f9e7c723629ba84a231b4b5b9774ca6de7b.tar.gz
gentoo-bd130f9e7c723629ba84a231b4b5b9774ca6de7b.tar.bz2
gentoo-bd130f9e7c723629ba84a231b4b5b9774ca6de7b.zip
net-libs/libsearpc: update EAPI 7 -> 8
* EAPI 8 by default disable static libraries Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild b/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
index ca9505393e11..c19c1820eaf0 100644
--- a/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
+++ b/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=(python3_{8,9})
-
-WANT_AUTOMAKE=1.16
+PYTHON_COMPAT=( python3_{8..9} )
inherit autotools python-single-r1
@@ -16,7 +14,6 @@ SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
@@ -35,6 +32,6 @@ src_prepare() {
src_install() {
default
- # Remove unnecessary .la and .a files
- find "${ED}" -name '*.la' -o -name '*.a' -delete || die
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
}