summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <dilfridge@gentoo.org>2017-10-13 11:11:55 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2017-10-13 11:13:47 +0200
commit73632b8414463dac0f34a7a4ed10ff60cee232aa (patch)
tree4287528ed164d4840119fc04d30533c4c932c3d7 /net-mail/isync/isync-9999.ebuild
parentdev-libs/libiconv: add Prefix support (diff)
downloadgentoo-73632b8414463dac0f34a7a4ed10ff60cee232aa.tar.gz
gentoo-73632b8414463dac0f34a7a4ed10ff60cee232aa.tar.bz2
gentoo-73632b8414463dac0f34a7a4ed10ff60cee232aa.zip
net-mail/isync: Add live ebuild and add myself to maintainers, acked by radhermit
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-mail/isync/isync-9999.ebuild')
-rw-r--r--net-mail/isync/isync-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/isync/isync-9999.ebuild b/net-mail/isync/isync-9999.ebuild
new file mode 100644
index 000000000000..492843925c9d
--- /dev/null
+++ b/net-mail/isync/isync-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="MailDir mailbox synchronizer"
+HOMEPAGE="http://isync.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/${PN}"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+IUSE="compat libressl sasl ssl zlib"
+
+RDEPEND="
+ >=sys-libs/db-4.2:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.6:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare () {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure () {
+ econf \
+ $(use_enable compat) \
+ $(use_with ssl) \
+ $(use_with sasl) \
+ $(use_with zlib)
+}