summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:34 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:34 +0100
commit181d152380aa77d302585b7f5048df95775c0b4f (patch)
treeb7b36ef22333bb55e9550414e902820890b38cad /net-mail/safecat/files
parentnet-libs/enet: Remove old (diff)
downloadgentoo-181d152380aa77d302585b7f5048df95775c0b4f.tar.gz
gentoo-181d152380aa77d302585b7f5048df95775c0b4f.tar.bz2
gentoo-181d152380aa77d302585b7f5048df95775c0b4f.zip
net-mail/safecat: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-mail/safecat/files')
-rw-r--r--net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch b/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch
new file mode 100644
index 000000000000..59bd33b0f760
--- /dev/null
+++ b/net-mail/safecat/files/safecat-1.13-head-tail-POSIX.patch
@@ -0,0 +1,45 @@
+--- a/make-compile.sh
++++ b/make-compile.sh
+@@ -1 +1 @@
+-echo exec "$CC" "`head -1 conf-includes`" -c '${1+"$@"}'
++echo exec "$CC" "`head -n 1 conf-includes`" -c '${1+"$@"}'
+--- a/Makefile
++++ b/Makefile
+@@ -17,8 +17,8 @@
+ auto-ccld.sh: \
+ conf-cc conf-ld warn-auto.sh
+ ( cat warn-auto.sh; \
+- echo CC=\'`head -1 conf-cc`\'; \
+- echo LD=\'`head -1 conf-ld`\'; \
++ echo CC=\'`head -n 1 conf-cc`\'; \
++ echo LD=\'`head -n 1 conf-ld`\'; \
+ ) > auto-ccld.sh
+
+ auto-str: \
+@@ -31,7 +31,7 @@
+
+ auto_home.c: \
+ auto-str conf-root
+- ./auto-str auto_home `head -1 conf-root` > auto_home.c
++ ./auto-str auto_home `head -n 1 conf-root` > auto_home.c
+
+ auto_home.o: \
+ compile auto_home.c
+@@ -161,7 +161,7 @@
+ maildir: \
+ warn-auto.sh maildir.sh conf-root
+ cat warn-auto.sh maildir.sh \
+- | sed s}HOME}"`head -1 conf-root`"}g \
++ | sed s}HOME}"`head -n 1 conf-root`"}g \
+ > maildir
+ chmod 755 maildir
+
+@@ -407,7 +407,7 @@
+ version.h: \
+ conf-version
+ @echo 'static const char *const version_string="$$Version:' \
+- `head -1 conf-version` 'built' `date +"%b %d, %Y"` at \
++ `head -n 1 conf-version` 'built' `date +"%b %d, %Y"` at \
+ `date +"%H:%M"`'$$";' > version.h
+
+ writefile.o: \