summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-10-10 21:25:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-26 12:14:52 +0200
commit1a74d04b93d24d1104544b43730be4402b83aede (patch)
tree370623c9f3603f734b5295e53654567428626e36 /net-mail/swaks
parentx11-themes/e-flat-theme: clean old 2020-08 snapshot (diff)
downloadgentoo-1a74d04b93d24d1104544b43730be4402b83aede.tar.gz
gentoo-1a74d04b93d24d1104544b43730be4402b83aede.tar.bz2
gentoo-1a74d04b93d24d1104544b43730be4402b83aede.zip
net-mail/swaks: New upstream version 20201014.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Closes: https://github.com/gentoo/gentoo/pull/17878 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-mail/swaks')
-rw-r--r--net-mail/swaks/Manifest1
-rw-r--r--net-mail/swaks/swaks-20201014.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/swaks/Manifest b/net-mail/swaks/Manifest
index 2ccb63dceea5..a5f686636f71 100644
--- a/net-mail/swaks/Manifest
+++ b/net-mail/swaks/Manifest
@@ -1,2 +1,3 @@
DIST swaks-20130209.0.tar.gz 102227 BLAKE2B 4726da81869e137458f1a3776c51ae33215999bef56b1835cf8558166bd756a8186900b83c0bf32a81d1ab1cf23ec379061f4db78ae5efa51de7a6c1a69d0092 SHA512 bf3c639f2c227d8219d5bc98a3d3519886471168c16e38d036283eeb1bb786c80bb80a648637150b3eb1903ef0c0d01bc37fd7b4f55af66a20f7bef18067b118
DIST swaks-20190914.0.tar.gz 120803 BLAKE2B 68731c22fbff5ece5c9589c3767afd6aa4fc781df8c6124a0f57d48a3dff8def31ccae1b043e78f7c066194cfe480a0edeb16e43fcd5e1b1aa75b05e65a2367e SHA512 3167435a73e7729d090cba2431d5828895c25154c36d92e0ebecd5c4e2430ca596d62bb3e6eb3b65eadabd52c8331fe3bb8a492cce3ad247fa113c0af9c67339
+DIST swaks-20201014.0.tar.gz 110953 BLAKE2B 8dd2c681c6c1e66b76bda71f0bc8b88e658565b28c29ae9f02e5c27500619598e5817a442aa82c48fd90be80cd2dc54eda8390ad3d1cb2e00163cc07a526f463 SHA512 8a4e8dc810a9c5943afdbc4db7130e110c42e211d6927ce1cdbab6f81fa49c31490e6c3668ec3cea79580c07b281ce30901b3b4a71325951167158cc9d70d9cc
diff --git a/net-mail/swaks/swaks-20201014.0.ebuild b/net-mail/swaks/swaks-20201014.0.ebuild
new file mode 100644
index 000000000000..cb8965894549
--- /dev/null
+++ b/net-mail/swaks/swaks-20201014.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-functions
+
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="https://www.jetmore.org/john/code/swaks/
+https://github.com/jetmore/swaks"
+SRC_URI="http://www.jetmore.org/john/code/swaks/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-perl/Authen-DigestMD5-0.04
+ >=dev-perl/Authen-NTLM-1.02
+ >=dev-perl/Net-DNS-0.65
+ >=virtual/perl-Digest-MD5-2.39
+ >=virtual/perl-MIME-Base64-3.07
+ >=virtual/perl-Time-HiRes-1.97
+ >=virtual/perl-Time-Local-1.19
+ dev-perl/CGI
+ dev-perl/DBI
+ dev-perl/Email-Send
+ dev-perl/Email-Valid
+ dev-perl/Params-Validate
+ dev-perl/URI
+ virtual/perl-Data-Dumper
+ virtual/perl-Digest-SHA
+ virtual/perl-Getopt-Long
+"
+BDEPEND="app-text/txt2man"
+
+src_compile() {
+ /usr/bin/txt2man -s 1 -t "${PN}" -v "Mail tools" doc/ref.txt \
+ > swaks.1 \
+ || die "man page compulation failed"
+}
+
+src_install() {
+ dobin swaks
+ doman swaks.1
+ dodoc README.txt doc/*.txt
+}
+
+pkg_postinst() {
+ optfeature "ssl" dev-perl/IO-Socket-SSL
+}