summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-06-30 15:11:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-06-30 18:57:24 +0200
commit0e5910cc468bba38539422ff42c82af1f5aca66d (patch)
tree365af1ff12d4f74833e7f605877900fea43bf285 /net-mail
parentsys-block/mmc-utils: add 0_p20240402 (diff)
downloadgentoo-0e5910cc468bba38539422ff42c82af1f5aca66d.tar.gz
gentoo-0e5910cc468bba38539422ff42c82af1f5aca66d.tar.bz2
gentoo-0e5910cc468bba38539422ff42c82af1f5aca66d.zip
net-mail/swaks: add 20240103.0 with ARM64 support, use more optfeatures
* Fix dependencies based on https://github.com/jetmore/swaks/blob/v20240103.0/swaks#L1933-L1953 and move everything not strictly necessary to opftfeature. * Use EAPI 8. * Use https for SRC_URI. Co-authored-by: Alarig Le Lay <alarig@swordarmor.fr> Signed-off-by: Louis Sautier <sbraz@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/37377
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/swaks/Manifest1
-rw-r--r--net-mail/swaks/swaks-20240103.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/swaks/Manifest b/net-mail/swaks/Manifest
index fd5e8ba0b3a8..7037038956ac 100644
--- a/net-mail/swaks/Manifest
+++ b/net-mail/swaks/Manifest
@@ -1 +1,2 @@
DIST swaks-20201014.0.tar.gz 110953 BLAKE2B 8dd2c681c6c1e66b76bda71f0bc8b88e658565b28c29ae9f02e5c27500619598e5817a442aa82c48fd90be80cd2dc54eda8390ad3d1cb2e00163cc07a526f463 SHA512 8a4e8dc810a9c5943afdbc4db7130e110c42e211d6927ce1cdbab6f81fa49c31490e6c3668ec3cea79580c07b281ce30901b3b4a71325951167158cc9d70d9cc
+DIST swaks-20240103.0.tar.gz 121308 BLAKE2B 7146c17181c854a474a57e3fc4d2337af910159802c6c2137b48bfb03d54579835b9eecb987874e122ae793c15e3718efd1f1962dc5508878b59afbc5182b658 SHA512 89d62cdb94630666c1acb1feb3b62585f36b4d59d14e56d998da6efe45538e9f5072379eebee43dd7244aa3981dbd8d6eb9a42ff7fa21a73127d171b8b3189f5
diff --git a/net-mail/swaks/swaks-20240103.0.ebuild b/net-mail/swaks/swaks-20240103.0.ebuild
new file mode 100644
index 000000000000..3d4d0004140b
--- /dev/null
+++ b/net-mail/swaks/swaks-20240103.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="https://www.jetmore.org/john/code/swaks/
+ https://github.com/jetmore/swaks"
+SRC_URI="https://www.jetmore.org/john/code/swaks/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/perl-Getopt-Long
+"
+BDEPEND="app-text/txt2man"
+
+src_compile() {
+ txt2man -s 1 -t "swaks" -v "Mail tools" doc/ref.txt \
+ > swaks.1 \
+ || die "man page compilation failed"
+}
+
+src_install() {
+ dobin swaks
+ doman swaks.1
+ dodoc README.txt doc/*.txt
+}
+
+pkg_postinst() {
+ # See https://github.com/jetmore/swaks/blob/v20240103.0/swaks#L1933-L1953
+ local header="Install the following additional packages for optional runtime features.\n"
+ header+="You may also check the output of 'swaks --support' to list currently available features:"
+ optfeature_header "$header"
+ optfeature "Basic auth support" virtual/perl-MIME-Base64
+ optfeature "AUTH CRAM-MD5 support" virtual/perl-Digest-MD5
+ optfeature "AUTH CRAM-SHA1 support" virtual/perl-Digest-SHA
+ optfeature "AUTH NTLM support" dev-perl/Authen-NTLM
+ optfeature "AUTH DIGEST-MD5 support" dev-perl/Authen-SASL
+ optfeature "MX routing support" dev-perl/Net-DNS
+ optfeature "TLS support" dev-perl/Net-SSLeay
+ optfeature "High Resolution Timing support" virtual/perl-Time-HiRes
+}