summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-12 06:18:17 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-12 06:19:13 -0400
commiteb840cb6d273f6467b6ba096fbb048133279de99 (patch)
treec7794c5635024df7daec64ba92656d98c9ca506f /net-mail
parentx11-themes/gtk-engines-adwaita: Stable for HPPA (bug #611134). (diff)
downloadgentoo-eb840cb6d273f6467b6ba096fbb048133279de99.tar.gz
gentoo-eb840cb6d273f6467b6ba096fbb048133279de99.tar.bz2
gentoo-eb840cb6d273f6467b6ba096fbb048133279de99.zip
net-mail/offlineimap: version bump to 7.0.14
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.14.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index 989e8b9d0be8..dfc1e449017c 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -3,3 +3,4 @@ DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61
DIST offlineimap-7.0.10.tar.gz 694812 SHA256 725431c20775d2524ed823da356b0b8f7cf627be518caafce808f23d797d1541 SHA512 76bdfed588068b53254c497ae9deaceaabbe432e187f4f069b0cfca3729fcb6c426bc364a095e081619e385242838f2da259529814faaf9ab509c9518c87dcf1 WHIRLPOOL 2e654ca36fe13eb237c3ac562281120e1c3bd32f44d0ca8843f9a91939c2b42809fa9b2b00881bd4972ff576ac458695da8e302e2e8f1a7e190431a9b1ac664c
DIST offlineimap-7.0.12.tar.gz 695070 SHA256 7fdad62ed59eb817969465dcba794271f8f84aa51d31ace9994865dbf9b934d4 SHA512 250376e83a5fe4f3652a9c3977100f11fe518a9955bda127f39f2ef360bb77fb4f108e44e6fc36a4f0f85dea02596f0eb2a48cb4d2fff1e02c9cc45c60c8679b WHIRLPOOL b5bfc0a7c38dab7774e33761c5e7235140561c550513c640961b31207cccb9f73250543ac009fb6db55de3962a7fedecb2f9f1d235f27dd370546dacffd5b447
DIST offlineimap-7.0.13.tar.gz 696783 SHA256 f744843f943c6adaa754e1244e16bfd6eaa825affe385169f16475db191787ce SHA512 d15a0f574b5793859bd32a646c2bb89e28a5d74aa2a86cafa07bc0d6bdbfac31f7a87b61aff3209e8897a0e3959c4bc4fd81aa9c9057f512afa64a919be87482 WHIRLPOOL 72ba3bd4fe0578deacc50b4c16ec81b20bfa2569d2fedb05d162d021ecb8d74ee245e27a5da87f25fe22aa8671ff5a4e5b19f25fc59d4bc61248a8bbc1221270
+DIST offlineimap-7.0.14.tar.gz 698081 SHA256 19494ecad4d7234ac69480abb7462d0cdcfcec444b55f5381651057d9fdfad44 SHA512 05d5ee81e5b0483038ad3bf8ba27f7b57423a75a3456df192c0c8b7926d7252424ef8f357f99dee2fa2f2590341e9f95d225ee2ad7d01af3466fb9d5488541f9 WHIRLPOOL a791cb67f1e51197fce9005ffbbbbdb8f4ee986d78a7ba46feff6aed6b50e17c5e57a9fa03bba9db0f90325b92c23b9d76071d460f6fec60fa878616cfc6544a
diff --git a/net-mail/offlineimap/offlineimap-7.0.14.ebuild b/net-mail/offlineimap/offlineimap-7.0.14.ebuild
new file mode 100644
index 000000000000..c38b4b231571
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.0.14.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}