summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-09-19 16:31:58 +0300
committerMichał Górny <mgorny@gentoo.org>2018-09-30 13:44:32 +0200
commitbbf7d6bf4cc16f1c0ab5604fe6019f78dcfb1e02 (patch)
treed245d5ca92c939962cce99ee9c8da8681a9202c3 /net-misc/econnman/econnman-1.1.ebuild
parentsci-visualization/tensorboard: dont unvendor tensorflow_serving (diff)
downloadgentoo-bbf7d6bf4cc16f1c0ab5604fe6019f78dcfb1e02.tar.gz
gentoo-bbf7d6bf4cc16f1c0ab5604fe6019f78dcfb1e02.tar.bz2
gentoo-bbf7d6bf4cc16f1c0ab5604fe6019f78dcfb1e02.zip
net-misc/econnman: new package
Closes: https://bugs.gentoo.org/473262 Signed-off-by: Joonas Niilola <juippis@gmail.com> Package-Manager: Portage[mgorny]-2.3.43.3 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9913
Diffstat (limited to 'net-misc/econnman/econnman-1.1.ebuild')
-rw-r--r--net-misc/econnman/econnman-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/econnman/econnman-1.1.ebuild b/net-misc/econnman/econnman-1.1.ebuild
new file mode 100644
index 000000000000..c8d70fe25a94
--- /dev/null
+++ b/net-misc/econnman/econnman-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4..7} )
+
+inherit python-single-r1
+
+DESCRIPTION="ConnMan User Interface written with EFL & python"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/econnman/ https://www.enlightenment.org/"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ ${DEPEND}
+ dev-libs/efl[X,connman]
+ dev-python/python-efl[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+ python_fix_shebang econnman-bin.in
+}