summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/fatrat/fatrat-1.2.0_beta2.ebuild')
-rw-r--r--net-misc/fatrat/fatrat-1.2.0_beta2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
new file mode 100644
index 000000000000..4fabdb966616
--- /dev/null
+++ b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4-based download/upload manager"
+HOMEPAGE="http://fatrat.dolezel.info/"
+SRC_URI="http://www.dolezel.info/download/data/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bittorrent +curl doc xmpp nls webinterface"
+
+RDEPEND="dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ bittorrent? ( >=net-libs/rb_libtorrent-0.14.5
+ >=dev-cpp/asio-1.1.0
+ dev-qt/qtwebkit:4 )
+ curl? ( >=net-misc/curl-7.18.2 )
+ doc? ( dev-qt/qthelp:4 )
+ xmpp? ( net-libs/gloox )
+ webinterface? ( dev-qt/qtscript:4 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libcrypto_linking.patch"
+)
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_with bittorrent) \
+ $(cmake-utils_use_with curl) \
+ $(cmake-utils_use_with doc DOCUMENTATION) \
+ $(cmake-utils_use_with xmpp JABBER) \
+ $(cmake-utils_use_with nls) \
+ $(cmake-utils_use_with webinterface)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ use bittorrent && echo "MimeType=application/x-bittorrent;" >> "${S}"/data/${PN}.desktop
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ # this is a completely optional and NOT automagic dep
+ if ! has_version dev-libs/geoip; then
+ elog "If you want the GeoIP support, then emerge dev-libs/geoip."
+ fi
+}