summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-25 20:41:17 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-25 20:52:06 +0200
commit4613ff3c586cea81dd660a2ca054ffce5ea76603 (patch)
tree3dab2fd52269062c3b4594cd6ea341b516ef75a8 /net-misc/gallery-dl
parentnet-misc/gallery-dl: drop old 1.27.3 (diff)
downloadgentoo-4613ff3c586cea81dd660a2ca054ffce5ea76603.tar.gz
gentoo-4613ff3c586cea81dd660a2ca054ffce5ea76603.tar.bz2
gentoo-4613ff3c586cea81dd660a2ca054ffce5ea76603.zip
net-misc/gallery-dl: bump to 1.27.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.27.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index be138f4ffcb7..b9a434f0f50a 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,3 +1,4 @@
DIST gallery-dl-1.27.4.gh.tar.gz 707554 BLAKE2B 09868291bf01db3db9bf4521a39a2443c6fe82cbd68f5840ff0d14a911bee56a649d89fcec3d2e705b0cabc54c18a0f04eee2fc8bb40e3b99803ea393e5d35f8 SHA512 7e22abbe77929ee4ef420f586b018796c00b8dc18b7ea709fe85bc51ac9fc467ba8763fcec4ab2afe108fd0fbb9002980970e037e1af2408e9c6504db1891220
DIST gallery-dl-1.27.5.gh.tar.gz 722422 BLAKE2B cd15c00549e9ed9605b39b76b271932ce3beae24b58e60c6fdd549f50d15cd949b14c19634067a24db2056c773be4e4811e9872a811cf6043a9e1edcdfec37dd SHA512 fb5895f4845582bc04bb3fe354bbd4f7611d5fde3caba723139e9bf5bd49796c82a2e6eed1ceca8e19d65136caf187eb6a64f9e93d4c64b89aa46e639e384852
DIST gallery-dl-1.27.6.gh.tar.gz 730206 BLAKE2B 4b47cb50599d401e3b3edf726afbe175e82b1617397cdd9c0ce389f1e43b16ece6d94dc44a015e515bb3e397f52b11f863e56b12fccb3bedc8e5d9e39fd90bcc SHA512 a72c30e0c7e64fb7eb8fd2b5a8de0c0b1570b5c2fc13adaddeb0a1ce9e721b299132b2e7ebbf932155b8880283c1b3e2783e037151557a167a8664ef01cce0f8
+DIST gallery-dl-1.27.7.gh.tar.gz 738516 BLAKE2B af29a40de14c392101c50698ae2199f64b458c8e5ab997982625773f21b069d5b3133c1a7897a743255962c5494e0536f36f4c4067872a06761a5a3a333e44ca SHA512 384c5a5c7dfac01ad48dbbe12750e5bec5814620bebd1d49866a9a3b6d64f7aac60e4173f737ed2678c6d57e372b6957cb747d28444981a4ddb7721bd4f9cff9
diff --git a/net-misc/gallery-dl/gallery-dl-1.27.7.ebuild b/net-misc/gallery-dl/gallery-dl-1.27.7.ebuild
new file mode 100644
index 000000000000..c785e9eeb31f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.27.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{12..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm test/test_results.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}