summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-06 23:35:10 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-07 01:11:16 +0200
commit9a8b7a9462f4abae3dbc7d52824ea23435c2858b (patch)
tree1a6dac59a253bc90bdec18ec94b972bc89e39c66 /net-misc/gallery-dl
parentdev-libs/weston: Bump PYTHON_COMPAT for Python 3.13 (diff)
downloadgentoo-9a8b7a9462f4abae3dbc7d52824ea23435c2858b.tar.gz
gentoo-9a8b7a9462f4abae3dbc7d52824ea23435c2858b.tar.bz2
gentoo-9a8b7a9462f4abae3dbc7d52824ea23435c2858b.zip
net-misc/gallery-dl: bump to 1.27.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.27.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 09893092e163..46b77c5b9d07 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.27.1.gh.tar.gz 686087 BLAKE2B c80f37d314671637f435957abf9d79d01d421e48c89e90a3290e6fbf6e32f89d4b7495deeaf2ce0528750b65d4b404108fe78bc42f0e39dda4bcfd4267aa9dff SHA512 d3243bd23e7a743d98b9745d78b653546a49a97dd8468b60014fa6ba74071de8057c8b479dc3d74854b4c194034b027fe15bc530a60dea34dcc6221b105c285c
DIST gallery-dl-1.27.3.gh.tar.gz 699804 BLAKE2B e1ded03fe94abcc442f4010e7e4cf51fbe1724543544761ccd318e61eb33146dbf25229d50123b9d0018b30dc6bffb895b022b61f6f5937dd77ea85f689206f2 SHA512 3fdee99af361364f7f1a207378c07efc24b3090f721da1dca3391972bdac4f31823e6711ac69ca6afca8de23fe276758af910179d511f739ec43b4408bbab6e6
+DIST gallery-dl-1.27.4.gh.tar.gz 707554 BLAKE2B 09868291bf01db3db9bf4521a39a2443c6fe82cbd68f5840ff0d14a911bee56a649d89fcec3d2e705b0cabc54c18a0f04eee2fc8bb40e3b99803ea393e5d35f8 SHA512 7e22abbe77929ee4ef420f586b018796c00b8dc18b7ea709fe85bc51ac9fc467ba8763fcec4ab2afe108fd0fbb9002980970e037e1af2408e9c6504db1891220
diff --git a/net-misc/gallery-dl/gallery-dl-1.27.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.27.4.ebuild
new file mode 100644
index 000000000000..e06bebddb525
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.27.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{11..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm test/test_results.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}