summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-15 12:03:04 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-15 12:05:02 +0200
commit0e8ac086f89a57f077e9e4e49a44b5c212ac4a5d (patch)
treec49a454cb1eaa9d94fa539cf67a4501fd6dd4295 /net-misc/iperf/iperf-3.99999.99999.ebuild
parentdev-ada/gnatcoll-core: version bump to 2020 (diff)
downloadgentoo-0e8ac086f89a57f077e9e4e49a44b5c212ac4a5d.tar.gz
gentoo-0e8ac086f89a57f077e9e4e49a44b5c212ac4a5d.tar.bz2
gentoo-0e8ac086f89a57f077e9e4e49a44b5c212ac4a5d.zip
net-misc/iperf: Drop IUSE=profiling
The configure flag only takes care of compiling an iperf3_profile binary and not installing same. Anyone interested in that could use EXTRA_ECONF=--enable-profiling instead. Package-Manager: Portage-2.3.101, Repoman-2.3.22 Closes: https://bugs.gentoo.org/727930 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/iperf/iperf-3.99999.99999.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.99999.99999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-misc/iperf/iperf-3.99999.99999.ebuild b/net-misc/iperf/iperf-3.99999.99999.ebuild
index f50078047e0e..14dfc1e065cd 100644
--- a/net-misc/iperf/iperf-3.99999.99999.ebuild
+++ b/net-misc/iperf/iperf-3.99999.99999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils git-r3 ltprune
+EAPI=7
+inherit autotools git-r3
DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
HOMEPAGE="https://github.com/esnet/iperf/"
@@ -11,26 +11,28 @@ EGIT_REPO_URI="https://github.com/esnet/iperf/"
LICENSE="BSD"
SLOT="3"
KEYWORDS=""
-IUSE="libressl profiling sctp static-libs"
+IUSE="libressl sctp static-libs"
DEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sctp? ( net-misc/lksctp-tools )
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
S=${WORKDIR}/${P/_/}
+DOCS="README.md RELNOTES.md"
src_configure() {
- use sctp || export ac_cv_header_netinet_sctp_h=no
econf \
- $(use_enable profiling) \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ $(use_with sctp)
}
src_install() {
default
newconfd "${FILESDIR}"/iperf.confd iperf3
newinitd "${FILESDIR}"/iperf3.initd iperf3
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}