summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/libss7/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/libss7/files')
-rw-r--r--net-misc/libss7/files/1.0.2-ldflags.patch12
-rw-r--r--net-misc/libss7/files/1.0.2-no-ldconfig.patch11
-rw-r--r--net-misc/libss7/files/1.0.2-werror-idiocy.patch12
3 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/libss7/files/1.0.2-ldflags.patch b/net-misc/libss7/files/1.0.2-ldflags.patch
new file mode 100644
index 000000000000..d88fe25237b7
--- /dev/null
+++ b/net-misc/libss7/files/1.0.2-ldflags.patch
@@ -0,0 +1,12 @@
+diff -uNr libss7-1.0.2.ORIG/Makefile libss7-1.0.2/Makefile
+--- libss7-1.0.2.ORIG/Makefile 2012-08-23 10:49:15.341155719 +0100
++++ libss7-1.0.2/Makefile 2012-08-23 10:50:35.403236983 +0100
+@@ -54,7 +54,7 @@
+ ranlib $(STATIC_LIBRARY)
+
+ $(DYNAMIC_LIBRARY): $(DYNAMIC_OBJS)
+- $(CC) -shared $(SOFLAGS) -o $@ $(DYNAMIC_OBJS)
++ $(CC) -shared $(SOFLAGS) $(LDFLAGS) -o $@ $(DYNAMIC_OBJS)
+ $(LDCONFIG) $(LDCONFIG_FLAGS) .
+ ln -sf libss7.so.1 libss7.so
+ ln -sf libss7.so.1.0 libss7.so.1
diff --git a/net-misc/libss7/files/1.0.2-no-ldconfig.patch b/net-misc/libss7/files/1.0.2-no-ldconfig.patch
new file mode 100644
index 000000000000..166fd01745cb
--- /dev/null
+++ b/net-misc/libss7/files/1.0.2-no-ldconfig.patch
@@ -0,0 +1,11 @@
+diff -uNr libss7-1.0.2.ORIG/Makefile libss7-1.0.2/Makefile
+--- libss7-1.0.2.ORIG/Makefile 2012-08-23 10:26:35.733775711 +0100
++++ libss7-1.0.2/Makefile 2012-08-23 10:27:06.826807271 +0100
+@@ -48,7 +48,6 @@
+ install -m 755 $(DYNAMIC_LIBRARY) $(INSTALL_PREFIX)$(libdir)
+ ( cd $(INSTALL_PREFIX)$(libdir) ; ln -sf libss7.so.1 libss7.so ; ln -sf libss7.so.1.0 libss7.so.1 )
+ install -m 644 $(STATIC_LIBRARY) $(INSTALL_PREFIX)$(libdir)
+- if test $$(id -u) = 0; then $(LDCONFIG); fi
+
+ $(STATIC_LIBRARY): $(STATIC_OBJS)
+ ar rcs $(STATIC_LIBRARY) $(STATIC_OBJS)
diff --git a/net-misc/libss7/files/1.0.2-werror-idiocy.patch b/net-misc/libss7/files/1.0.2-werror-idiocy.patch
new file mode 100644
index 000000000000..8eed3e5e2196
--- /dev/null
+++ b/net-misc/libss7/files/1.0.2-werror-idiocy.patch
@@ -0,0 +1,12 @@
+diff -uNr libss7-1.0.2.ORIG/Makefile libss7-1.0.2/Makefile
+--- libss7-1.0.2.ORIG/Makefile 2012-08-23 10:22:27.855524115 +0100
++++ libss7-1.0.2/Makefile 2012-08-23 10:22:46.156542689 +0100
+@@ -11,7 +11,7 @@
+ DYNAMIC_OBJS=mtp2.o ss7_sched.o ss7.o mtp3.o isup.o version.o
+ STATIC_LIBRARY=libss7.a
+ DYNAMIC_LIBRARY=libss7.so.1.0
+-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC
++CFLAGS=-Wall -Wstrict-prototypes -Wmissing-prototypes -g -fPIC
+ LDCONFIG_FLAGS=-n
+ SOFLAGS=-Wl,-hlibss7.so.1
+ LDCONFIG=/sbin/ldconfig