summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-09-05 12:33:04 +0200
committerPacho Ramos <pacho@gentoo.org>2015-09-05 12:33:04 +0200
commit7e9c8aeb134da151be0d6d09a846e20d8387518c (patch)
tree0beba37a5f8742f8036bd6edae8b036fc5f697cf /net-misc/networkmanager/files
parentnet-misc/networkmanager: ia64 rekeyword now that deps are ok (diff)
downloadgentoo-7e9c8aeb134da151be0d6d09a846e20d8387518c.tar.gz
gentoo-7e9c8aeb134da151be0d6d09a846e20d8387518c.tar.bz2
gentoo-7e9c8aeb134da151be0d6d09a846e20d8387518c.zip
net-misc/networkmanager: Remove more obsolete files and old and vulnerable versions
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc/networkmanager/files')
-rw-r--r--net-misc/networkmanager/files/networkmanager-0.9.10.0-arpingpath.patch16
-rw-r--r--net-misc/networkmanager/files/networkmanager-0.9.8.4-pre-sleep.patch131
-rw-r--r--net-misc/networkmanager/files/networkmanager-0.9.8.9-fix-crash-on-wifi-rescan.patch47
-rw-r--r--net-misc/networkmanager/files/networkmanager-1.0.0-find-helpers.patch23
-rw-r--r--net-misc/networkmanager/files/networkmanager-1.0.0-lto-switch.patch36
-rw-r--r--net-misc/networkmanager/files/networkmanager-1.0.0-remove-bashisms.patch44
-rw-r--r--net-misc/networkmanager/files/nm-system-settings.conf-ifnet6
7 files changed, 0 insertions, 303 deletions
diff --git a/net-misc/networkmanager/files/networkmanager-0.9.10.0-arpingpath.patch b/net-misc/networkmanager/files/networkmanager-0.9.10.0-arpingpath.patch
deleted file mode 100644
index f8e0d5260014..000000000000
--- a/net-misc/networkmanager/files/networkmanager-0.9.10.0-arpingpath.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Source: Timo Gurr <tgurr@exherbo.org>
-Upstream: Reported, https://bugzilla.gnome.org/show_bug.cgi?id=734131
-Reason: fix hardcoded path to arping
-
-diff -Naur NetworkManager-0.9.10.0.old/src/devices/nm-device.c NetworkManager-0.9.10.0/src/devices/nm-device.c
---- NetworkManager-0.9.10.0.old/src/devices/nm-device.c 2014-07-04 02:44:19.000000000 +0200
-+++ NetworkManager-0.9.10.0/src/devices/nm-device.c 2014-09-01 17:35:29.656282068 +0200
-@@ -4429,7 +4429,7 @@
- static void
- send_arps (NMDevice *self, const char *mode_arg)
- {
-- const char *argv[] = { "/sbin/arping", mode_arg, "-q", "-I", nm_device_get_ip_iface (self), "-c", "1", NULL, NULL };
-+ const char *argv[] = { "/bin/arping", mode_arg, "-q", "-I", nm_device_get_ip_iface (self), "-c", "1", NULL, NULL };
- int ip_arg = G_N_ELEMENTS (argv) - 2;
- NMConnection *connection;
- NMSettingIP4Config *s_ip4;
diff --git a/net-misc/networkmanager/files/networkmanager-0.9.8.4-pre-sleep.patch b/net-misc/networkmanager/files/networkmanager-0.9.8.4-pre-sleep.patch
deleted file mode 100644
index 6e6dfbe8ee29..000000000000
--- a/net-misc/networkmanager/files/networkmanager-0.9.8.4-pre-sleep.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From ffb08fa288cea4c9ac8f18fd83e063b2e86ac51b Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Sun, 27 Jan 2013 23:39:56 -0500
-Subject: [PATCH] Implement "pre-sleep" action dispatch
-
-Based on work by Christian Becke <christianbecke@gmail.com> in
-https://bugzilla.gnome.org/show_bug.cgi?id=387832
----
- callouts/nm-dispatcher-utils.c | 3 ++-
- src/nm-dispatcher.c | 8 ++++++--
- src/nm-dispatcher.h | 3 ++-
- src/nm-manager.c | 28 +++++++++++++++++++++-------
- 4 files changed, 31 insertions(+), 11 deletions(-)
-
-diff --git a/callouts/nm-dispatcher-utils.c b/callouts/nm-dispatcher-utils.c
-index 8824295..66cbc4b 100644
---- a/callouts/nm-dispatcher-utils.c
-+++ b/callouts/nm-dispatcher-utils.c
-@@ -409,7 +409,8 @@ nm_dispatcher_utils_construct_envp (const char *action,
- g_return_val_if_fail (*out_iface == NULL, NULL);
-
- /* Hostname changes don't require a device nor contain a connection */
-- if (!strcmp (action, "hostname"))
-+ if (!strcmp (action, "hostname") ||
-+ !strcmp (action, "pre-sleep"))
- return g_new0 (char *, 1);
-
- /* Canonicalize the VPN interface name; "" is used when passing it through
-diff --git a/src/nm-dispatcher.c b/src/nm-dispatcher.c
-index 12cd0f0..42d7e12 100644
---- a/src/nm-dispatcher.c
-+++ b/src/nm-dispatcher.c
-@@ -237,6 +237,8 @@ action_to_string (DispatcherAction action)
- return "dhcp4-change";
- case DISPATCHER_ACTION_DHCP6_CHANGE:
- return "dhcp6-change";
-+ case DISPATCHER_ACTION_PRE_SLEEP:
-+ return "pre-sleep";
- default:
- break;
- }
-@@ -269,7 +271,8 @@ _dispatcher_call (DispatcherAction action,
- DispatchInfo *info;
-
- /* All actions except 'hostname' require a device */
-- if (action != DISPATCHER_ACTION_HOSTNAME)
-+ if (action != DISPATCHER_ACTION_HOSTNAME &&
-+ action != DISPATCHER_ACTION_PRE_SLEEP)
- g_return_val_if_fail (NM_IS_DEVICE (device), NULL);
- /* VPN actions require at least an IPv4 config (for now) */
- if (action == DISPATCHER_ACTION_VPN_UP)
-@@ -308,7 +311,8 @@ _dispatcher_call (DispatcherAction action,
- vpn_ip6_props = value_hash_create ();
-
- /* hostname actions only send the hostname */
-- if (action != DISPATCHER_ACTION_HOSTNAME) {
-+ if (action != DISPATCHER_ACTION_HOSTNAME &&
-+ action != DISPATCHER_ACTION_PRE_SLEEP) {
- fill_device_props (device,
- device_props,
- device_ip4_props,
-diff --git a/src/nm-dispatcher.h b/src/nm-dispatcher.h
-index 05a6c87..8e95834 100644
---- a/src/nm-dispatcher.h
-+++ b/src/nm-dispatcher.h
-@@ -39,7 +39,8 @@ typedef enum {
- DISPATCHER_ACTION_VPN_PRE_DOWN,
- DISPATCHER_ACTION_VPN_DOWN,
- DISPATCHER_ACTION_DHCP4_CHANGE,
-- DISPATCHER_ACTION_DHCP6_CHANGE
-+ DISPATCHER_ACTION_DHCP6_CHANGE,
-+ DISPATCHER_ACTION_PRE_SLEEP = 999,
- } DispatcherAction;
-
- typedef void (*DispatcherFunc) (gconstpointer call, gpointer user_data);
-diff --git a/src/nm-manager.c b/src/nm-manager.c
-index 811f49d..f52956d 100644
---- a/src/nm-manager.c
-+++ b/src/nm-manager.c
-@@ -73,6 +73,7 @@
- #include "nm-sleep-monitor.h"
- #include "nm-connectivity.h"
- #include "nm-policy.h"
-+#include "nm-dispatcher.h"
-
-
- #define NM_AUTOIP_DBUS_SERVICE "org.freedesktop.nm_avahi_autoipd"
-@@ -3350,6 +3351,23 @@ impl_manager_deactivate_connection (NMManager *self,
- }
-
- static void
-+pre_sleep_dispatcher_done (gpointer call, gpointer user_data)
-+{
-+ NMManager *self = (NMManager *) user_data;
-+ NMManagerPrivate *priv = NM_MANAGER_GET_PRIVATE (self);
-+ GSList *iter;
-+
-+ /* Just deactivate and down all devices from the device list,
-+ * to keep things fast the device list will get resynced when
-+ * the manager wakes up.
-+ */
-+ for (iter = priv->devices; iter; iter = iter->next)
-+ nm_device_set_managed (NM_DEVICE (iter->data), FALSE, NM_DEVICE_STATE_REASON_SLEEPING);
-+
-+ nm_manager_update_state (self);
-+}
-+
-+static void
- do_sleep_wake (NMManager *self)
- {
- NMManagerPrivate *priv = NM_MANAGER_GET_PRIVATE (self);
-@@ -3359,13 +3377,9 @@ do_sleep_wake (NMManager *self)
- if (manager_sleeping (self)) {
- nm_log_info (LOGD_SUSPEND, "sleeping or disabling...");
-
-- /* Just deactivate and down all devices from the device list,
-- * to keep things fast the device list will get resynced when
-- * the manager wakes up.
-- */
-- for (iter = priv->devices; iter; iter = iter->next)
-- nm_device_set_managed (NM_DEVICE (iter->data), FALSE, NM_DEVICE_STATE_REASON_SLEEPING);
--
-+ nm_dispatcher_call (DISPATCHER_ACTION_PRE_SLEEP, NULL, NULL,
-+ pre_sleep_dispatcher_done, self);
-+ return;
- } else {
- nm_log_info (LOGD_SUSPEND, "waking up and re-enabling...");
-
---
-1.8.3.2
-
diff --git a/net-misc/networkmanager/files/networkmanager-0.9.8.9-fix-crash-on-wifi-rescan.patch b/net-misc/networkmanager/files/networkmanager-0.9.8.9-fix-crash-on-wifi-rescan.patch
deleted file mode 100644
index 35e9c04aff4b..000000000000
--- a/net-misc/networkmanager/files/networkmanager-0.9.8.9-fix-crash-on-wifi-rescan.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 4099c9242b091604466dda081dc5f6909354258b Mon Sep 17 00:00:00 2001
-From: M. Vefa Bicakci <m.v.b@runbox.com>
-Date: Sat, 24 May 2014 23:37:00 +0000
-Subject: core: fix crash during Wi-Fi rescan by emitting NM_DEVICE_AUTH_REQUEST signal correctly
-
-Fixes regression introduced by commit da59b6d2229b85afbb9e14846931376340dc6030.
-
-https://mail.gnome.org/archives/networkmanager-list/2014-May/msg00038.html
-
-Backport-of: d9653484859c426f707b4759bc9882f7a57c1152
-[thaller@redhat.com: original patch modified in nm-device-wifi.c to pass no
- connection, as it is done on master]
-Signed-off-by: Thomas Haller <thaller@redhat.com>
----
-diff --git a/src/nm-device-wifi.c b/src/nm-device-wifi.c
-index 8ca5278..052d68f 100644
---- a/src/nm-device-wifi.c
-+++ b/src/nm-device-wifi.c
-@@ -1563,6 +1563,7 @@ impl_device_request_scan (NMDeviceWifi *self,
- g_signal_emit_by_name (device,
- NM_DEVICE_AUTH_REQUEST,
- context,
-+ NULL,
- NM_AUTH_PERMISSION_NETWORK_CONTROL,
- TRUE,
- request_scan_cb,
-diff --git a/src/nm-manager.c b/src/nm-manager.c
-index 9037e64..96bf3b4 100644
---- a/src/nm-manager.c
-+++ b/src/nm-manager.c
-@@ -1874,10 +1874,10 @@ device_auth_request_cb (NMDevice *device,
- }
-
- /* Ensure the subject has permissions for this connection */
-- if (!nm_auth_uid_in_acl (connection,
-- priv->session_monitor,
-- sender_uid,
-- &error_desc)) {
-+ if (connection != NULL && !nm_auth_uid_in_acl (connection,
-+ priv->session_monitor,
-+ sender_uid,
-+ &error_desc)) {
- error = g_error_new_literal (NM_MANAGER_ERROR,
- NM_MANAGER_ERROR_PERMISSION_DENIED,
- error_desc);
---
-cgit v0.9.0.2-2-gbebe
diff --git a/net-misc/networkmanager/files/networkmanager-1.0.0-find-helpers.patch b/net-misc/networkmanager/files/networkmanager-1.0.0-find-helpers.patch
deleted file mode 100644
index a84909c8253e..000000000000
--- a/net-misc/networkmanager/files/networkmanager-1.0.0-find-helpers.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 6f643d2761650e53fd3b647526110a8473138b5d Mon Sep 17 00:00:00 2001
-From: Thomas Haller <thaller@redhat.com>
-Date: Thu, 8 Jan 2015 11:55:50 +0100
-Subject: core: add /bin to the default search path
-
-https://bugzilla.gnome.org/show_bug.cgi?id=742576
-(cherry picked from commit abbca50ca9d552a28eca792f12ec618df6128fff)
-
-diff --git a/src/NetworkManagerUtils.c b/src/NetworkManagerUtils.c
-index 2c291cd..6747b65 100644
---- a/src/NetworkManagerUtils.c
-+++ b/src/NetworkManagerUtils.c
-@@ -814,6 +814,7 @@ const char *const NM_PATHS_DEFAULT[] = {
- "/sbin/",
- "/usr/sbin/",
- "/usr/local/sbin/",
-+ "/bin/",
- "/usr/bin/",
- "/usr/local/bin/",
- NULL,
---
-cgit v0.10.2
-
diff --git a/net-misc/networkmanager/files/networkmanager-1.0.0-lto-switch.patch b/net-misc/networkmanager/files/networkmanager-1.0.0-lto-switch.patch
deleted file mode 100644
index 5d66c3393c71..000000000000
--- a/net-misc/networkmanager/files/networkmanager-1.0.0-lto-switch.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From cda2802fe960737abb4623166ca4f75a63b5fe5a Mon Sep 17 00:00:00 2001
-From: Thomas Haller <thaller@redhat.com>
-Date: Thu, 8 Jan 2015 12:01:32 +0100
-Subject: build: fix --enable-lto configure option to allow disabling option
- explicitly
-
-When specifying '--enable-lto=anything' or '--disable-lto',
-the configure script would always set enable_lto=yes.
-
-The only way to disable lto, was *not* specifying the
-configure option.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=742575
-(cherry picked from commit 6eccfda0face594f86dea495d2ed2546b0d37e77)
-
-diff --git a/configure.ac b/configure.ac
-index b6bf38e..b407686 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -821,10 +821,11 @@ AM_CONDITIONAL(BUILD_NMTUI, test "$build_nmtui" = yes)
-
- NM_COMPILER_WARNINGS
-
--AC_ARG_ENABLE(lto, AS_HELP_STRING([--enable-lto], [Enable Link Time Optimization for smaller size (default: no)]),
-- [enable_lto=yes], [enable_lto=no])
-+AC_ARG_ENABLE(lto, AS_HELP_STRING([--enable-lto], [Enable Link Time Optimization for smaller size (default: no)]))
- if (test "${enable_lto}" = "yes"); then
- CFLAGS="-flto $CFLAGS"
-+else
-+ enable_lto='no'
- fi
-
-
---
-cgit v0.10.2
-
diff --git a/net-misc/networkmanager/files/networkmanager-1.0.0-remove-bashisms.patch b/net-misc/networkmanager/files/networkmanager-1.0.0-remove-bashisms.patch
deleted file mode 100644
index 366627f7eb18..000000000000
--- a/net-misc/networkmanager/files/networkmanager-1.0.0-remove-bashisms.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 4c3c9a38272112fe7a6a248ba521d55ac1b66892 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
-Date: Sun, 25 Jan 2015 13:02:19 +0100
-Subject: [PATCH] build: use POSIX-compliant 'printf' instead of 'echo'
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fixes the following error when running ./configure with dash:
-
- checking for QT... yes
- checking for moc-qt4... no
- checking for moc... moc
- configure: error: --with-udev-dir must be an absolute path or 'yes' or
- 'no'. Instead it is '/lib/udev'
-
-As per the Autoconf Manual's section on "Limitations of Shell Builtins":
-
- The simple echo is probably the most surprising source of portability
- troubles. It is not possible to use ‘echo’ portably unless both
- options and escape sequences are omitted.
-
-https://www.gnu.org/software/automake/faq/autoconf.html#echo
-https://bugs.gentoo.org/536540
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index b407686..5c87c7e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -302,7 +302,7 @@ AM_CONDITIONAL(WITH_QT, test "${enable_qt}" = "yes")
-
- AC_ARG_WITH(udev-dir, AS_HELP_STRING([--with-udev-dir=DIR], [Absolute path of the udev base directory. Set to 'no' not to install the udev rules]), [], [with_udev_dir="yes"])
- if (test "$with_udev_dir" != 'no'); then
-- if (test "$with_udev_dir" != 'yes' && echo -n "$with_udev_dir" | grep -v -q '^/'); then
-+ if (test "$with_udev_dir" != 'yes' && printf '%s' "$with_udev_dir" | grep -v -q '^/'); then
- AC_MSG_ERROR([--with-udev-dir must be an absolute path or 'yes' or 'no'. Instead it is '$with_udev_dir'])
- fi
- if (test "$with_udev_dir" = 'yes'); then
---
-2.2.1
-
diff --git a/net-misc/networkmanager/files/nm-system-settings.conf-ifnet b/net-misc/networkmanager/files/nm-system-settings.conf-ifnet
deleted file mode 100644
index 4d14ee7b8041..000000000000
--- a/net-misc/networkmanager/files/nm-system-settings.conf-ifnet
+++ /dev/null
@@ -1,6 +0,0 @@
-[main]
-plugins=ifnet,keyfile
-
-[ifnet]
-managed=true
-auto_refresh=false