summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2018-10-02 12:25:04 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-10-06 12:17:21 -0400
commitd3541e15805fb156b478ad0c00806c81b0a75265 (patch)
tree0780223246db75b7ba83c6908b5aeaa65ea2d487 /net-misc/nyx
parentnet-misc/nyx: update to support live ebuild (diff)
downloadgentoo-d3541e15805fb156b478ad0c00806c81b0a75265.tar.gz
gentoo-d3541e15805fb156b478ad0c00806c81b0a75265.tar.bz2
gentoo-d3541e15805fb156b478ad0c00806c81b0a75265.zip
net-misc/nyx: add a -9999
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/nyx-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-9999.ebuild b/net-misc/nyx/nyx-9999.ebuild
new file mode 100644
index 000000000000..a27cb04c7b15
--- /dev/null
+++ b/net-misc/nyx/nyx-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ net-libs/stem
+ net-vpn/tor"