summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-06-12 17:50:06 +0530
committerZac Medico <zmedico@gentoo.org>2024-06-13 12:10:42 -0700
commit0e2b07ac3f950ecaed7e551bd8b3941288fce5bf (patch)
tree92a8674ce35971ed275805602aabd27270572105 /net-misc/passt
parentapp-containers/podman: update to 5.1.1 (diff)
downloadgentoo-0e2b07ac3f950ecaed7e551bd8b3941288fce5bf.tar.gz
gentoo-0e2b07ac3f950ecaed7e551bd8b3941288fce5bf.tar.bz2
gentoo-0e2b07ac3f950ecaed7e551bd8b3941288fce5bf.zip
net-misc/passt: update to 2024.06.07
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> From: https://github.com/gentoo/gentoo/pull/37135 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc/passt')
-rw-r--r--net-misc/passt/Manifest1
-rw-r--r--net-misc/passt/passt-2024.06.07.ebuild40
-rw-r--r--net-misc/passt/passt-9999.ebuild2
3 files changed, 42 insertions, 1 deletions
diff --git a/net-misc/passt/Manifest b/net-misc/passt/Manifest
index 58e08ceca1b8..d1b7a339a1a1 100644
--- a/net-misc/passt/Manifest
+++ b/net-misc/passt/Manifest
@@ -2,3 +2,4 @@ DIST passt-2024.03.26.tar.xz 195348 BLAKE2B d91e6ac1d50aae04ceb53a34341b545ff644
DIST passt-2024.04.05.tar.xz 195772 BLAKE2B 4c237aeda56455f948d4309624d171612d59fa7ec653e7f89c1aeb05c677ccbdeeaaf6e14c09cda1d5bc88a97fca57dbbe480095e9711045fbd381bd30fb644a SHA512 bf14689cb1c4780d4249562965ff9a5a0515756cbf5af4b531c17982a066f33001a65210959ff8da691ddaa75560ab5691c685a4c1a4b73e742a883d12d2a24b
DIST passt-2024.04.26.tar.xz 196148 BLAKE2B f3a9b9d2a9fa42e0dd35894d4c92890af9935965ccfb3b1751c396080ab0482bd541fe22f09ae7b068f336f1e985b6905d2cc93987a17f243ba6ec97d880ee68 SHA512 f25b9bc695de555048f6a24ec9bb603ec6def0449227ce837b6e46f8cda5816c2450aa733257aaa349260b0b7c05b2d5580ad21010a1a45a74e9eb3027e37d98
DIST passt-2024.05.10.tar.xz 195992 BLAKE2B 9f4b680daa8103c7de0c92c01824df74e1b221a48cf7724c2c09aae13a3575bdc529eeca01d5015095c51194045e1019bbdf38cc7ef2333d61eaa03b4e0249ae SHA512 04add1113ffbc98d61b7c63352899505d8f19bbdf937a0c025726813163ec7fc31abdb94c12ceefed9b49f18b388acc0687298bce8ba156bbb044d1b1bcdaee3
+DIST passt-2024.06.07.tar.xz 198360 BLAKE2B 378d4b18f245309fde54b244ffc435afb417d9d9711247234632ba0ae8dea35cac639c7674e6a6be008a678262af74a1dbe960477088d0b75045e6372d329488 SHA512 103955058c9a4e83264d3f65e3ff6d1a5e8a83b15f2fc73cba45101304fe79ab3c449ce2dc6add398a27f9d6556d5f902cf083223ed5e27228a0bbb506559cf0
diff --git a/net-misc/passt/passt-2024.06.07.ebuild b/net-misc/passt/passt-2024.06.07.ebuild
new file mode 100644
index 000000000000..65a98bc9f51b
--- /dev/null
+++ b/net-misc/passt/passt-2024.06.07.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="8a83b53"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
index 9e4992ffaab0..65a98bc9f51b 100644
--- a/net-misc/passt/passt-9999.ebuild
+++ b/net-misc/passt/passt-9999.ebuild
@@ -8,7 +8,7 @@ inherit toolchain-funcs
DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
HOMEPAGE="https://passt.top/"
-RELEASE_COMMIT="7288448"
+RELEASE_COMMIT="8a83b53"
if [[ ${PV} == 9999* ]]; then
inherit git-r3