summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-08-24 10:29:53 +0200
committerZac Medico <zmedico@gentoo.org>2024-08-24 08:27:18 -0700
commit652f17bcfc5b13438990110166cc20f569375999 (patch)
tree9a63f3a9df05ac7c91554cd9d3a1a16b211d1e6f /net-misc/passt
parentapp-portage/elt-patches: add 20240824 (diff)
downloadgentoo-652f17bcfc5b13438990110166cc20f569375999.tar.gz
gentoo-652f17bcfc5b13438990110166cc20f569375999.tar.bz2
gentoo-652f17bcfc5b13438990110166cc20f569375999.zip
net-misc/passt: use https:// instead of git:// for cloning
git:// is unencrypted and could be used by an attacker (mitm) to insert malicious code, see also [1]. git:// runs on port 9418 which is also less likely open behind a firewall. [1] git-scm.com/book/en/v2/Git-on-the-Server-The-Protocols Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> From: https://github.com/gentoo/gentoo/pull/38276 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc/passt')
-rw-r--r--net-misc/passt/passt-2024.03.26.ebuild2
-rw-r--r--net-misc/passt/passt-2024.04.05.ebuild2
-rw-r--r--net-misc/passt/passt-2024.04.26.ebuild2
-rw-r--r--net-misc/passt/passt-2024.05.10.ebuild2
-rw-r--r--net-misc/passt/passt-2024.06.07.ebuild2
-rw-r--r--net-misc/passt/passt-9999.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/net-misc/passt/passt-2024.03.26.ebuild b/net-misc/passt/passt-2024.03.26.ebuild
index 90df839f93d9..91d818f5b4a1 100644
--- a/net-misc/passt/passt-2024.03.26.ebuild
+++ b/net-misc/passt/passt-2024.03.26.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="4988e2b"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
diff --git a/net-misc/passt/passt-2024.04.05.ebuild b/net-misc/passt/passt-2024.04.05.ebuild
index e4201215e520..be03e08a6fab 100644
--- a/net-misc/passt/passt-2024.04.05.ebuild
+++ b/net-misc/passt/passt-2024.04.05.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="954589b"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
diff --git a/net-misc/passt/passt-2024.04.26.ebuild b/net-misc/passt/passt-2024.04.26.ebuild
index c73a0f7c146b..cf83c50f72ed 100644
--- a/net-misc/passt/passt-2024.04.26.ebuild
+++ b/net-misc/passt/passt-2024.04.26.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="d03c4e2"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
diff --git a/net-misc/passt/passt-2024.05.10.ebuild b/net-misc/passt/passt-2024.05.10.ebuild
index ce44d6abe4eb..022bbfc62aa7 100644
--- a/net-misc/passt/passt-2024.05.10.ebuild
+++ b/net-misc/passt/passt-2024.05.10.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="7288448"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
diff --git a/net-misc/passt/passt-2024.06.07.ebuild b/net-misc/passt/passt-2024.06.07.ebuild
index 9ffe1a0980df..37ba4d13c25f 100644
--- a/net-misc/passt/passt-2024.06.07.ebuild
+++ b/net-misc/passt/passt-2024.06.07.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="8a83b53"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
index 9ffe1a0980df..37ba4d13c25f 100644
--- a/net-misc/passt/passt-9999.ebuild
+++ b/net-misc/passt/passt-9999.ebuild
@@ -12,7 +12,7 @@ RELEASE_COMMIT="8a83b53"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="git://passt.top/passt"
+ EGIT_REPO_URI="https://passt.top/passt"
else
SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"