summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-13 21:05:29 -0500
committerSam James <sam@gentoo.org>2023-12-24 19:20:38 +0000
commit1a239e5168ea0c9f8bd8417dad3ae46afdd30b5c (patch)
tree8e61c4ada81fc76f19acf92dcc04600d0acd57dd /net-misc/seafile
parentnet-misc/seafile: drop old (diff)
downloadgentoo-1a239e5168ea0c9f8bd8417dad3ae46afdd30b5c.tar.gz
gentoo-1a239e5168ea0c9f8bd8417dad3ae46afdd30b5c.tar.bz2
gentoo-1a239e5168ea0c9f8bd8417dad3ae46afdd30b5c.zip
net-misc/seafile: drop outdated dependency on dev-python/future
Removed upstream in 7.0.8 via https://github.com/haiwen/seafile/commit/7e337a32333d2767d1dd3fe6e7f84f62011a3c10 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34389 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/seafile')
-rw-r--r--net-misc/seafile/seafile-8.0.9-r2.ebuild62
-rw-r--r--net-misc/seafile/seafile-9.0.3-r1.ebuild (renamed from net-misc/seafile/seafile-9.0.3.ebuild)3
2 files changed, 62 insertions, 3 deletions
diff --git a/net-misc/seafile/seafile-8.0.9-r2.ebuild b/net-misc/seafile/seafile-8.0.9-r2.ebuild
new file mode 100644
index 000000000000..9b5d65d24c4b
--- /dev/null
+++ b/net-misc/seafile/seafile-8.0.9-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# Upstream is moving tags repeatedly, then we use commit hash.
+# (Please file a bug upstream if this happens!)
+#RELEASE_COMMIT="6bd36a957573eda6a53f3d1bc538dbfc001aa9fd"
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+#SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+SRC_URI="https://github.com/haiwen/seafile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/jansson:=
+ dev-libs/libevent:=
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ $(vala_depend)"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ vala_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"/usr/bin/seaf-cli
+}
diff --git a/net-misc/seafile/seafile-9.0.3.ebuild b/net-misc/seafile/seafile-9.0.3-r1.ebuild
index 12f795caa8dc..0fe9c3b19303 100644
--- a/net-misc/seafile/seafile-9.0.3.ebuild
+++ b/net-misc/seafile/seafile-9.0.3-r1.ebuild
@@ -20,9 +20,6 @@ KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/future[${PYTHON_USEDEP}]
- ')
dev-libs/openssl:=
dev-db/sqlite:3
dev-libs/glib:2