summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 03:40:26 +0100
committerSam James <sam@gentoo.org>2023-05-16 04:35:53 +0100
commitce8e25973d4599a418eed89d9e2e778ffaea45ed (patch)
tree0b9fecaecddc792a2d107a55270763c7bca03e8f /net-misc/spice-gtk
parentsys-libs/libraw1394: add Valgrind annotation support (diff)
downloadgentoo-ce8e25973d4599a418eed89d9e2e778ffaea45ed.tar.gz
gentoo-ce8e25973d4599a418eed89d9e2e778ffaea45ed.tar.bz2
gentoo-ce8e25973d4599a418eed89d9e2e778ffaea45ed.zip
net-misc/spice-gtk: add Valgrind annotation support
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.42.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-misc/spice-gtk/spice-gtk-0.42.ebuild b/net-misc/spice-gtk/spice-gtk-0.42.ebuild
index edfe353dc093..2e31ef2729a7 100644
--- a/net-misc/spice-gtk/spice-gtk-0.42.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.42.ebuild
@@ -24,7 +24,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+gtk3 +introspection lz4 mjpeg policykit sasl smartcard usbredir vala wayland webdav"
+IUSE="+gtk3 +introspection lz4 mjpeg policykit sasl smartcard usbredir vala valgrind wayland webdav"
# TODO:
# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
@@ -71,7 +71,8 @@ RDEPEND="${RDEPEND}
x86? ( media-libs/libva:= )
"
DEPEND="${RDEPEND}
- >=app-emulation/spice-protocol-${SPICE_PROTOCOL_VER}"
+ >=app-emulation/spice-protocol-${SPICE_PROTOCOL_VER}
+ valgrind? ( dev-util/valgrind )"
BDEPEND="
dev-perl/Text-CSV
dev-util/glib-utils
@@ -106,6 +107,7 @@ src_configure() {
$(meson_feature smartcard)
$(meson_feature usbredir)
$(meson_feature vala vapi)
+ $(meson_use valgrind)
$(meson_feature webdav)
$(meson_feature wayland wayland-protocols)
)