summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-11-29 03:35:19 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-11-29 03:35:38 -0500
commitacc27f8afb32905d2674ff1714134277e1ac49e9 (patch)
tree5f87a326ef69b06143f41a821e645d72a8dda62c /net-misc/stunnel
parentmedia-sound/musescore: Version bump and dependency fixes. (diff)
downloadgentoo-acc27f8afb32905d2674ff1714134277e1ac49e9.tar.gz
gentoo-acc27f8afb32905d2674ff1714134277e1ac49e9.tar.bz2
gentoo-acc27f8afb32905d2674ff1714134277e1ac49e9.zip
net-misc/stunnel: version bump to 5.38
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/Manifest1
-rw-r--r--net-misc/stunnel/stunnel-5.38.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-misc/stunnel/Manifest b/net-misc/stunnel/Manifest
index 5f2f67611af0..382aa358ad6d 100644
--- a/net-misc/stunnel/Manifest
+++ b/net-misc/stunnel/Manifest
@@ -2,3 +2,4 @@ DIST stunnel-5.34.tar.gz 644677 SHA256 786111168a84a5a01188dddfcecb37d8c69a4c725
DIST stunnel-5.35.tar.gz 645148 SHA256 ffa386ae4c825f35f35157c285e7402a6d58779ad8c3822f74a9d355b54aba1d SHA512 cdec7ddafbfac4a1d420704baec72fedbd655871137ec8283c066203c0859019c6e11ce00647e5b471a019409e4eb5e9525166eddd7ddffa25055b95c0cacd9e WHIRLPOOL 9d3c4538827ce94a27ad6922a2c4e38192ec8a3d23e0059e328651eaadf7c0696c8751174553bce801a2e940c34c164d871d76b7b623a59133cd0a5c6b00aed2
DIST stunnel-5.36.tar.gz 645205 SHA256 eb8952fcfdfcdf5056a1f1a78e1ec5014b819c5f5f7599b924dc4490ffe4b5ea SHA512 663dd155aab17b628fd1ef8ae1c604efc0cdf026566e98fbff16ba4da5b12b06cd6801bf4f604a9b2ea98d993c184ce97c63c1f716fa86b5e630e5fd504e3317 WHIRLPOOL 12f95a119b840b6afdcaf4d41ee325896bc89feda9ed172651dee1b52a3231fe1599c8fb6c69c1a0f93b342a3b785fb3d002a94a31b14678052313f224c48d0e
DIST stunnel-5.37.tar.gz 645336 SHA256 d0e3530e3effc64fdec792c71791d4937c6b8bd3b9ea4895c6bb6526dcd0d241 SHA512 b42dd9e0ea7d024ebbbb0729a0db9caeecfbe3296464f475caa9ee7927c42d762c51a597b6c3a261151bb863e4696fc7cc1c6fe270eb02731e11b29cd60e440a WHIRLPOOL db272f71cba5a7ff516c159c07adc953b7c1c5ce731161fd1bd9827e529ad64f7b7a5de6105ecee3fe225d9044846430c749fcd23b759098d7c7b63cc1b731ba
+DIST stunnel-5.38.tar.gz 647774 SHA256 09ada29ba1683ab1fd1f31d7bed8305127a0876537e836a40cb83851da034fd5 SHA512 29adae28955639ab7732ff0d7ea3c097211babcd0c8932717c582f5e38279811a0a209f1daa2c6a22cf69ef28b8b67439038625ba58683c268c322b19e43ac58 WHIRLPOOL ae549e6d498a0bf31591b32f56c4d97141e00485d66aa50be23c5022e9c73f5d51c91d685bf135bf12a365a9b56d53c2dded042ecd8810cbe19e74ca7f89cc5b
diff --git a/net-misc/stunnel/stunnel-5.38.ebuild b/net-misc/stunnel/stunnel-5.38.ebuild
new file mode 100644
index 000000000000..a8a6f7d4fe1b
--- /dev/null
+++ b/net-misc/stunnel/stunnel-5.38.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit ssl-cert eutils multilib systemd user
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://www.stunnel.org/index.html"
+SRC_URI="ftp://ftp.stunnel.org/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.usenix.org.uk/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://ftp.nluug.nl/pub/networking/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://www.namesdir.com/mirrors/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ http://stunnel.cybermirror.org/archive/${PV%%.*}.x/${P}.tar.gz
+ http://mirrors.zerg.biz/stunnel/archive/${PV%%.*}.x/${P}.tar.gz
+ ftp://mirrors.go-parts.com/stunnel/archive/${PV%%.*}.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ipv6 libressl selinux stunnel3 tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}
+ stunnel3? ( dev-lang/perl )
+ selinux? ( sec-policy/selinux-stunnel )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+}
+
+src_prepare() {
+ # Hack away generation of certificate
+ sed -i -e "s/^install-data-local:/do-not-run-this:/" \
+ tools/Makefile.in || die "sed failed"
+
+ # libressl compat
+ epatch "${FILESDIR}"/stunnel-compat-libressl.patch
+
+ echo "CONFIG_PROTECT=\"/etc/stunnel/stunnel.conf\"" > "${T}"/20stunnel
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_enable tcpd libwrap) \
+ --with-ssl="${EPREFIX}"/usr \
+ --disable-fips
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ use stunnel3 || rm -f "${ED}"/usr/bin/stunnel3
+
+ # The binary was moved to /usr/bin with 4.21,
+ # symlink for backwards compatibility
+ dosym ../bin/stunnel /usr/sbin/stunnel
+
+ dodoc AUTHORS BUGS CREDITS PORTS README TODO ChangeLog
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ doins "${FILESDIR}"/stunnel.conf
+ newinitd "${FILESDIR}"/stunnel-r1 stunnel
+
+ doenvd "${T}"/20stunnel
+
+ systemd_dounit "${S}/tools/stunnel.service"
+ systemd_newtmpfilesd "${FILESDIR}"/stunnel.tmpfiles.conf stunnel.conf
+}
+
+pkg_postinst() {
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
+ install_cert /etc/stunnel/stunnel
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ fi
+
+ einfo "If you want to run multiple instances of stunnel, create a new config"
+ einfo "file ending with .conf in /etc/stunnel/. **Make sure** you change "
+ einfo "\'pid= \' with a unique filename."
+}