summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-01 10:38:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-01 10:52:00 +0200
commitc46d0754582a150d9b7c4a6732c5078f625d0c50 (patch)
tree056e89ae0f2044a6a89eacecf157c35f12336b5d /net-misc/teamviewer
parentprofiles/arch/arm64: unmask app-editors/vscode (diff)
downloadgentoo-c46d0754582a150d9b7c4a6732c5078f625d0c50.tar.gz
gentoo-c46d0754582a150d9b7c4a6732c5078f625d0c50.tar.bz2
gentoo-c46d0754582a150d9b7c4a6732c5078f625d0c50.zip
net-misc/teamviewer: bump to v15.18.5
Closes: https://bugs.gentoo.org/786300 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/teamviewer')
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-15.18.5.ebuild139
2 files changed, 141 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index 32b10b72d057..346dd5edd021 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -2,3 +2,5 @@ DIST teamviewer_15.15.5_amd64.tar.xz 13264432 BLAKE2B 8f23c036b79c7ee7cbef118182
DIST teamviewer_15.15.5_i386.tar.xz 13751236 BLAKE2B 32d8f6494c72b51feef54e2d5dd1096aee83c283a1d07680f428bd4321ede9975d1ee4e7cd55718f9250d54304d17887b98ae6e62617e7022ec78384fdde5a16 SHA512 315e6fcaa6d40aab17c47ac4eee6d894be3731ae7d0242e2b11bae279627de04540f8d46908826d53b6a6d275769c19a420c6f30e9869a734e87cb7d6832bfba
DIST teamviewer_15.17.6_amd64.tar.xz 13763464 BLAKE2B 5dde0947470611bd67bd8913355c965c0e206d2bd5243e27a4fa742e4fc2d3e0849132a6b2527d453c1f8aa2026cb65897bc2a3c83b493914aa8bd69b1d408d7 SHA512 1775e1fb1c35eceb9df1ec12fb5d7a6e7e9df739a211b99561f67665834bbea2bb80af4547841b73be386cae184861d0f40423936d38f9a2055ee30edd4095c0
DIST teamviewer_15.17.6_i386.tar.xz 14394028 BLAKE2B 4a5f7f72887c4ba391ae444eaba2c7c474b40fc0bfbe0c7745b4c925fbf7626862de162f49f115e41ccc0858cf7d6d813eadf0940d64217a6964b4d83526b0ad SHA512 f7b7a999069cb036b2b528651fb0737ca0dbcbe3b8283ca8281dd9c08f33b1aa44b7689c63816686538213cd10939dcc69510512ab61829ba7d4d7c6789709ba
+DIST teamviewer_15.18.5_amd64.tar.xz 14049816 BLAKE2B f3f32685f32c7cf10e6dacb9b11333fc5fd69a6039bfae4e872aaba2f71451873f5a6648056fb07a69fc44f83bb3067b6c72a5239eb0ce51f33b34ee595fd323 SHA512 5c60737a69c2777d555bc3ce76f43d38171fa4e8e0adf99c4ddece0b8852778c1ea630fe7d938cc6271aded4a6b0bbafec6cd3ccb79db304d0f7b9263bd93c5e
+DIST teamviewer_15.18.5_i386.tar.xz 14697088 BLAKE2B 85992ccfd946fdad245397b8ff9e9340bc608106bc2a8a5290f9e85c5aa012600f6b9c2fa42908d7c7228c089c6f941c25bf48f1424ff17cc87a97eadbb0073c SHA512 bf43108b919acc003384fa7ea342805ce7e6cd1016cf982f066e8e80756dc031d7ae9449ec18cd63e40c928a12dfd9a7138dc7d18943e68e93e72927dd651ab0
diff --git a/net-misc/teamviewer/teamviewer-15.18.5.ebuild b/net-misc/teamviewer/teamviewer-15.18.5.ebuild
new file mode 100644
index 000000000000..63c023804a57
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-15.18.5.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_MAJOR="$(ver_cut 1)"
+MY_P="${PN}${MY_MAJOR}"
+inherit desktop systemd xdg
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${MY_MAJOR}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${MY_MAJOR}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+ !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_P}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -i \
+ -e "/^ExecStart/s/${PN}/${MY_P}/" \
+ tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_P}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ local exe
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd15.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ local size
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png teamviewer.png
+ done
+
+ dodoc -r doc
+
+ # Make docs available in expected location
+ dosym ../../usr/share/doc/${PF}/doc ${dst}/doc
+
+ # We need to keep docs uncompressed, bug #778617
+ docompress -x /usr/share/doc/${PF}/*
+
+ keepdir /etc/${MY_P}
+ dosym ../../etc/${MY_P} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_P}
+ dosym ../../var/log/${MY_P} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${MY_MAJOR}" teamviewer
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+ elog
+ elog "Most likely TeamViewer will work normally only on systems with systemd"
+ elog "or elogind. See this thread for additional info:"
+ elog "https://forums.gentoo.org/viewtopic-p-8332956.html#8332956"
+ fi
+}