summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-12 20:58:50 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-12 21:00:18 +0200
commit18a8332773d3f5507add30108cd338c899ce06c0 (patch)
tree69569f06a64fc0600e923ee426a31ccb1a9ae893 /net-misc/youtube-dl
parentapp-admin/ansible: 2.3.0.0 bup (diff)
downloadgentoo-18a8332773d3f5507add30108cd338c899ce06c0.tar.gz
gentoo-18a8332773d3f5507add30108cd338c899ce06c0.tar.bz2
gentoo-18a8332773d3f5507add30108cd338c899ce06c0.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.04.11.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 77fe2d7df962..6190b9ac2397 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.04.03.tar.gz 2661559 SHA256 d313898eae80d4a26a08621088bd8816d176b31f330d7d9d6ce0f71381c0d0fd SHA512 37c54404c19c99e6ac3d221622503a6f4023cc4534b26ac7a012d0077ae706a220905b206aa3530ffaa41a840df1e3a5c098f834fac795bec1397384635a2e8c WHIRLPOOL 1bf75ceacd026cff5030888eb1ea7c0c4e4507cf406b10a089589d83b0cc57fc4c864d9258ac9b244ece6f92932f5e1443a39498b601344dda20357240d2ed1a
DIST youtube-dl-2017.04.09.tar.gz 2669689 SHA256 91bb2147ccf0bf505aeea0107b33b57e7503a6475b521cd0f8b9ea049f6fa22c SHA512 813e9258f8f56f40a3facbb9fac19d3fa8fea43c7842225129cf4c8fd744994d45ef46a54146e8fa5ca3a427301fdcdbcd50bf1ba0f2f914d80a1a93af559384 WHIRLPOOL 8a1d1b0c6fabdbc797a0cb41d02a320bf9a66a99054f619661c5af9aee717add61e51f93149814a5fd396f5e365c666997e63f0c72d0a76914c9d0b9a17904a6
+DIST youtube-dl-2017.04.11.tar.gz 2671689 SHA256 4df5af6b3199a93a7e4dc58de0c6da6759b065ceeeaac9470865a5cefdfdc149 SHA512 d831505902f4857a1701cc71286b3ad62e60eeafec3cec3ddde2fe74ff24a826b800146986d47c69bc74b1ef4bb15ae39174e1da34d04b19c859ce4c0f140c5b WHIRLPOOL 91a98c60ac9cb45dbfc3870e81d5d538047763136ba6f99ec21df74b6409f78062546e016cc7c4c5e89cdbcca61788382b783c22f2901dfec228e1edf4892c4b
diff --git a/net-misc/youtube-dl/youtube-dl-2017.04.11.ebuild b/net-misc/youtube-dl/youtube-dl-2017.04.11.ebuild
new file mode 100644
index 000000000000..0527ae290b0e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.04.11.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}