summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-28 18:39:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-28 19:03:18 +0100
commit758e0fe0e96b002eaaa7b0ae737fbca0c62f9946 (patch)
treecc056ec36808ec12b67fc89d13e89c5dafe1b8a1 /net-misc/ytmdl
parentdev-lang/dafny-bin: switch maint to dotnet@gentoo.org (diff)
downloadgentoo-758e0fe0e96b002eaaa7b0ae737fbca0c62f9946.tar.gz
gentoo-758e0fe0e96b002eaaa7b0ae737fbca0c62f9946.tar.bz2
gentoo-758e0fe0e96b002eaaa7b0ae737fbca0c62f9946.zip
net-misc/ytmdl: bump to 2023.2.28
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/ytmdl')
-rw-r--r--net-misc/ytmdl/Manifest1
-rw-r--r--net-misc/ytmdl/ytmdl-2023.2.28.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/ytmdl/Manifest b/net-misc/ytmdl/Manifest
index ba71a7a4ec39..dea8b38e2d45 100644
--- a/net-misc/ytmdl/Manifest
+++ b/net-misc/ytmdl/Manifest
@@ -1,2 +1,3 @@
DIST ytmdl-2022.12.25.tar.gz 52126 BLAKE2B f769ec1bd78f4d1ce53104c18c95df66722c31747e7b0b4f98bc96d56e1d8ee40d6be834b6f3c690dc8986182185c8e755b567fd488924ad08d5d2362d95e9e9 SHA512 543353ec951e80956ccbb9398d14237a02cc9ca66deaa41ce3b50c3d577b9930adf490777ccf7936a75a9a40524aea328fee62298d8ca2606a28ffa9ec17ba23
DIST ytmdl-2022.3.16.tar.gz 51115 BLAKE2B 504d0d0de299c8989bb289769cd43645199a7f47b683885efc6eafde5643ed070cc66eeaf7b1c8f42d547b25f830c3bd8feb9abc0124b28d4d1900e5cf785c9d SHA512 5ad67fb981d5f3ea42d2f097cecf982f0971e824c5971aa8fbc664303f436c623ab03a9f0e31dba060b27eb7eb57b88452ba1ede9eb3385dc6acead9fa43e0d0
+DIST ytmdl-2023.2.28.tar.gz 52281 BLAKE2B 5a9dfea6022082b976fb165ca45cb4ae13adac9308cb5671b52bd433eed4b2921bad345c3acaa10f125d06162964c55b82c44468e3d12b52c47ea63d2d1bce71 SHA512 891119c0386bd2079108b9b34f41606c2a6da21de5f574a89b95d6cb5a661611e442ffc10f6f4d94d827318568408ff8d5b58eb3eb602e64afa4efa3728b3855
diff --git a/net-misc/ytmdl/ytmdl-2023.2.28.ebuild b/net-misc/ytmdl/ytmdl-2023.2.28.ebuild
new file mode 100644
index 000000000000..7c908d1870ad
--- /dev/null
+++ b/net-misc/ytmdl/ytmdl-2023.2.28.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Simple app to get songs from youtube in mp3 format"
+HOMEPAGE="https://ytmdl.deepjyoti30.dev/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=net-misc/yt-dlp-2022.3.8.2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/ffmpeg-python[${PYTHON_USEDEP}]
+ dev-python/itunespy[${PYTHON_USEDEP}]
+ dev-python/pyDes[${PYTHON_USEDEP}]
+ dev-python/python-musicbrainzngs[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/simber[${PYTHON_USEDEP}]
+ dev-python/spotipy[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/youtube-search-python[${PYTHON_USEDEP}]
+ dev-python/ytmusicapi[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ net-misc/downloader-cli[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp ${PN}.bash ${PN}
+}