summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2018-05-23 15:27:35 +0000
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 15:59:36 -0400
commit0c47d898c3a2d660b78b0462114463c23b7616c9 (patch)
treec18c618edd414747cc0fba5d9c7e963c5efcabba /net-misc/zerotier/zerotier-1.2.12.ebuild
parentnet-irc/irssi: amd64 stable wrt bug #668534 (diff)
downloadgentoo-0c47d898c3a2d660b78b0462114463c23b7616c9.tar.gz
gentoo-0c47d898c3a2d660b78b0462114463c23b7616c9.tar.bz2
gentoo-0c47d898c3a2d660b78b0462114463c23b7616c9.zip
net-misc/zerotier: bump version to 1.2.12
Closes: https://bugs.gentoo.org/658042 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Package-Manager: Portage-2.3.24, Repoman-2.3.6 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'net-misc/zerotier/zerotier-1.2.12.ebuild')
-rw-r--r--net-misc/zerotier/zerotier-1.2.12.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/zerotier/zerotier-1.2.12.ebuild b/net-misc/zerotier/zerotier-1.2.12.ebuild
new file mode 100644
index 000000000000..7d2f788b42ec
--- /dev/null
+++ b/net-misc/zerotier/zerotier-1.2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic systemd toolchain-funcs
+
+HOMEPAGE="https://www.zerotier.com/"
+DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
+SRC_URI="https://github.com/zerotier/ZeroTierOne/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ZeroTierOne-${PV}"
+
+RDEPEND="
+ dev-libs/json-glib:=
+ net-libs/http-parser:=
+ net-libs/libnatpmp:=
+ net-libs/miniupnpc:="
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md AUTHORS.md )
+
+src_compile() {
+ append-ldflags -Wl,-z,noexecstack
+ emake CXX="$(tc-getCXX)" STRIP=: one
+}
+
+src_test() {
+ emake selftest
+ ./zerotier-selftest || die
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}".init "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}".service
+ doman doc/zerotier-{cli.1,idtool.1,one.8}
+}