summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-02-02 18:12:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-28 09:01:47 +0200
commit2b4ac4bd6ae654d14218883ac7a298cd1d2d5b42 (patch)
tree88c5b42b5dac473434dc471dcc448f0550a25601 /net-misc
parentdev-lang/elixir: add 1.16.1 (diff)
downloadgentoo-2b4ac4bd6ae654d14218883ac7a298cd1d2d5b42.tar.gz
gentoo-2b4ac4bd6ae654d14218883ac7a298cd1d2d5b42.tar.bz2
gentoo-2b4ac4bd6ae654d14218883ac7a298cd1d2d5b42.zip
net-misc/tinyssh: respect user CFLAGS
Closes: https://bugs.gentoo.org/887897 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tinyssh/files/tinyssh-20240101_conf_cflags.patch10
-rw-r--r--net-misc/tinyssh/tinyssh-20240101.ebuild7
2 files changed, 14 insertions, 3 deletions
diff --git a/net-misc/tinyssh/files/tinyssh-20240101_conf_cflags.patch b/net-misc/tinyssh/files/tinyssh-20240101_conf_cflags.patch
new file mode 100644
index 000000000000..8dd35d91b828
--- /dev/null
+++ b/net-misc/tinyssh/files/tinyssh-20240101_conf_cflags.patch
@@ -0,0 +1,10 @@
+diff --git a/conf-cflags b/conf-cflags
+--- a/conf-cflags
++++ b/conf-cflags
+@@ -15,6 +15,3 @@
+ -fstack-protector-strong
+ -fwrapv
+ -fno-strict-overflow
+--Os
+--fomit-frame-pointer
+--funroll-loops
diff --git a/net-misc/tinyssh/tinyssh-20240101.ebuild b/net-misc/tinyssh/tinyssh-20240101.ebuild
index 5164323fe0c6..0edea200702b 100644
--- a/net-misc/tinyssh/tinyssh-20240101.ebuild
+++ b/net-misc/tinyssh/tinyssh-20240101.ebuild
@@ -28,10 +28,11 @@ RDEPEND="
sys-apps/ucspi-tcp
"
-src_prepare() {
- # Leave optimization level to user CFLAGS
- sed -i 's/-Os -fomit-frame-pointer -funroll-loops//g' ./conf-cc || die
+PATCHES=(
+ "${FILESDIR}/tinyssh-20240101_conf_cflags.patch"
+)
+src_prepare() {
# Use make-tinysshcc.sh script, which has no tests and doesn't execute
# binaries. See https://github.com/janmojzis/tinyssh/issues/2
sed -i 's/make-tinyssh\.sh/make-tinysshcc.sh/g' ./Makefile || die