summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:23:00 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-09 17:23:06 +0200
commit72cfeb5d7d566a5263038bb3494ef7f95cd6c649 (patch)
treed1950882edd31a36f73678dfb9348dea8bd6e5b7 /net-misc
parentdev-python/python-lsp-jsonrpc: update EAPI 7 -> 8 (diff)
downloadgentoo-72cfeb5d7d566a5263038bb3494ef7f95cd6c649.tar.gz
gentoo-72cfeb5d7d566a5263038bb3494ef7f95cd6c649.tar.bz2
gentoo-72cfeb5d7d566a5263038bb3494ef7f95cd6c649.zip
net-misc/lyricwikia: update EAPI 7 -> 8, pep517, py3.12
Closes: https://bugs.gentoo.org/910008 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/lyricwikia/lyricwikia-0.1.11-r2.ebuild48
-rw-r--r--net-misc/lyricwikia/metadata.xml3
2 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/lyricwikia/lyricwikia-0.1.11-r2.ebuild b/net-misc/lyricwikia/lyricwikia-0.1.11-r2.ebuild
new file mode 100644
index 000000000000..e5c93282a1f9
--- /dev/null
+++ b/net-misc/lyricwikia/lyricwikia-0.1.11-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python API to get song lyrics from LyricWikia"
+HOMEPAGE="https://github.com/enricobacis/lyricwikia"
+SRC_URI="https://github.com/enricobacis/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="test? ( dev-python/responses[${PYTHON_USEDEP}] )"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES="${FILESDIR}/${P}-skip-online-test.patch"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not depend on deprecated dep
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # rename the executable to avoid file conflict with net-im/lyrics-in-terminal
+ find "${D}" -name 'lyrics' -execdir mv {} lyricwikia \; || die
+}
+
+pkg_postinst() {
+ elog "Note that access to LyricWikia through this API (and products that use this API) should comply to the LyricWikia terms of use"
+ elog ""
+ elog "LyricWikia is now offline, this package is provided solely for the purpose of satisfying media-video/vidify's dependencies"
+}
diff --git a/net-misc/lyricwikia/metadata.xml b/net-misc/lyricwikia/metadata.xml
index 270110553011..264f58e3938d 100644
--- a/net-misc/lyricwikia/metadata.xml
+++ b/net-misc/lyricwikia/metadata.xml
@@ -7,4 +7,7 @@
<name>Andrew Ammerlaan</name>
</maintainer>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">enricobacis/lyricwikia</remote-id>
+ </upstream>
</pkgmetadata>