summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-16 01:03:20 +0000
committerSam James <sam@gentoo.org>2023-01-16 01:03:28 +0000
commit8ef4cced7e1101ffeae1e96e33e60628c8bd9276 (patch)
tree010543c0f02dc6884490c6b8f6b4d54f2c313829 /net-misc
parentsys-devel/gdb: drop 13.0.50_p20221217 (diff)
downloadgentoo-8ef4cced7e1101ffeae1e96e33e60628c8bd9276.tar.gz
gentoo-8ef4cced7e1101ffeae1e96e33e60628c8bd9276.tar.bz2
gentoo-8ef4cced7e1101ffeae1e96e33e60628c8bd9276.zip
net-misc/streamlink: add 5.1.2
Closes: https://bugs.gentoo.org/876863 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-5.1.2.ebuild56
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild5
3 files changed, 61 insertions, 1 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index ca74518861a0..74e846bfcf92 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1 +1,2 @@
DIST streamlink-4.3.0.tar.gz 474184 BLAKE2B 557d70105f043fe7454d1c6dd7a49becfd354612df43d09242ec86da5275c7c629f6df887ee7e3a25d9c502e0845f38bece0da2335c5f09951cb4b0aada408a3 SHA512 e1c450d777c00515c07895303dccdece23a8a29b2f9cc272790f5d4b260adbb381845d7ffbc9425e6cee7be41d66158e226d14d08352430bff1c29889b0b0077
+DIST streamlink-5.1.2.tar.gz 494342 BLAKE2B f916aab0fcd346e9945de04335309c61cb83c7c5047208a281a87162fb19dae6e45ae861fbc55780049e63bd854f303ee1669d3664a3736debbf8194ee4e6760 SHA512 8fecdc46fc34b37a5a67d15bb4252d1ebab69815398deb533de063fdf7e211d23d413b1b519984dddd2bb5e35296d717dd0504a3578b7bc44c7b123cd70db2a3
diff --git a/net-misc/streamlink/streamlink-5.1.2.ebuild b/net-misc/streamlink/streamlink-5.1.2.ebuild
new file mode 100644
index 000000000000..ff7c51d0ed88
--- /dev/null
+++ b/net-misc/streamlink/streamlink-5.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index db619ea9b999..ff7c51d0ed88 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -27,6 +27,7 @@ SLOT="0"
DEPEND="
$(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
>dev-python/requests-2.21.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
@@ -34,6 +35,7 @@ DEPEND="
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
')
"
@@ -45,8 +47,9 @@ BDEPEND="
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
)
')"