summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-18 03:31:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-18 04:02:34 -0500
commite94f68f21601da4b1f130884f335dc9511f26687 (patch)
treeeda0eb5dfe3e30ff61a502ce031f267f878cc426 /net-misc
parentnet-misc/yt-dlp: drop 2024.10.07, 2024.10.22 (diff)
downloadgentoo-e94f68f21601da4b1f130884f335dc9511f26687.tar.gz
gentoo-e94f68f21601da4b1f130884f335dc9511f26687.tar.bz2
gentoo-e94f68f21601da4b1f130884f335dc9511f26687.zip
net-misc/yt-dlp: add 2024.11.18
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.11.18.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index a6a8ef76f9e8..7f5e457dd8b5 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2024.11.04.tar.gz 5790714 BLAKE2B 01e28d2058ee7f899b8046bb8409b4eadcc2eb4ed2881068a9710913fea92fb37c5f7e638d94d0d1ef8314549d161c5e5b2a4a4065ad9620610ddd73cbcdeb0f SHA512 6af8973ca83cd622cfd61bbdd02fea6db34eb9b3986b9b2c402b7828d1c9da6c2931fc616f43be08be5332c6b2b1707a9ed21a14b71f639a5891a0ecbd1baccd
+DIST yt-dlp-2024.11.18.tar.gz 5807807 BLAKE2B 342f7a6d4f94c19b7a74de8b020b80983b1860deac0a86fcd826d9b3fe5aa604388ff92a85c45fae32079e04ebf2d49517f472649d41973ed314793f163c920a SHA512 ef44b44a098796a22104e19414e6b3ca51635a2bdad9fe7635ed4781a9cd1743f754eb202dd6fbcc98838abe8b2bd85e999a5c6cc1f084c3709effc72d4e8b45
diff --git a/net-misc/yt-dlp/yt-dlp-2024.11.18.ebuild b/net-misc/yt-dlp/yt-dlp-2024.11.18.ebuild
new file mode 100644
index 000000000000..3de67e0bfb4a
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.11.18.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}