summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-15 09:52:27 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-02-17 10:48:43 +0300
commit367dddd2decd3134c8c55eae2ee1e733899a3f77 (patch)
treed097e337e7dae218cd826b2cd8b8e339a5f433aa /net-nds/shelldap
parentnet-nds/shelldap: remove old (diff)
downloadgentoo-367dddd2decd3134c8c55eae2ee1e733899a3f77.tar.gz
gentoo-367dddd2decd3134c8c55eae2ee1e733899a3f77.tar.bz2
gentoo-367dddd2decd3134c8c55eae2ee1e733899a3f77.zip
net-nds/shelldap: update to 1.5.1
Updated HOMEPAGE and SRC_URI, added missing dependency dev-perl/Tie-IxHash Closes: https://bugs.gentoo.org/709644 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'net-nds/shelldap')
-rw-r--r--net-nds/shelldap/Manifest1
-rw-r--r--net-nds/shelldap/shelldap-1.5.0.ebuild1
-rw-r--r--net-nds/shelldap/shelldap-1.5.1.ebuild43
3 files changed, 45 insertions, 0 deletions
diff --git a/net-nds/shelldap/Manifest b/net-nds/shelldap/Manifest
index 901673726ee2..2b9849f0aad6 100644
--- a/net-nds/shelldap/Manifest
+++ b/net-nds/shelldap/Manifest
@@ -1 +1,2 @@
DIST shelldap-1.5.0.tar.gz 22591 BLAKE2B ac6ed03fc05e8b5d247162ac08d68cc20d4303538af14c98e7fbbf6c1ccf4386c34f26e20715f095d5c0f3f3944f19950ca41ee82c21edfbe5a33a12e17a772f SHA512 036cfcb6e33baddf34dba56bed4ab2ad0a29f0c54067bfaa4fa8a12125dcf837a701920bed49b7f0693d0aacbd2665cad5400a8a46e8b416440500c6a4d0651a
+DIST shelldap-1.5.1.tar.gz 22817 BLAKE2B 8ec41edf8c7d024f5eaed286284445cc9d41fbdf93ae34229d32392dd6f4862b8b3e66b5735679a9019d505753994f3d1d8f0d6cefec9b55708ef982d757b009 SHA512 64e5f58aa2d930ff869abb0c88ba36a5aac1272f118af8d17a0db847d6ce4bdd9fe3b8fb6b2e9d08f89bec57a102adf170f2c9f6b98b5f3fe5c30ac3636a060a
diff --git a/net-nds/shelldap/shelldap-1.5.0.ebuild b/net-nds/shelldap/shelldap-1.5.0.ebuild
index 5ad7513307fc..33ac2881939e 100644
--- a/net-nds/shelldap/shelldap-1.5.0.ebuild
+++ b/net-nds/shelldap/shelldap-1.5.0.ebuild
@@ -24,6 +24,7 @@ RDEPEND="dev-perl/Algorithm-Diff
dev-perl/TermReadKey
readline? ( dev-perl/Term-ReadLine-Gnu )
dev-perl/Term-Shell
+ dev-perl/Tie-IxHash
dev-perl/YAML-Syck
virtual/perl-Data-Dumper
virtual/perl-File-Temp
diff --git a/net-nds/shelldap/shelldap-1.5.1.ebuild b/net-nds/shelldap/shelldap-1.5.1.ebuild
new file mode 100644
index 000000000000..eca62dabfd3d
--- /dev/null
+++ b/net-nds/shelldap/shelldap-1.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit eutils perl-module
+
+DESCRIPTION="A handy shell-like interface for browsing LDAP servers and editing their content"
+HOMEPAGE="https://github.com/mahlonsmith/shelldap https://bitbucket.org/mahlon/shelldap/"
+SRC_URI="https://github.com/mahlonsmith/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+readline sasl +ssl"
+
+RDEPEND="dev-perl/Algorithm-Diff
+ sasl? ( dev-perl/Authen-SASL )
+ dev-perl/IO-Socket-SSL
+ dev-perl/perl-ldap
+ dev-perl/TermReadKey
+ readline? ( dev-perl/Term-ReadLine-Gnu )
+ dev-perl/Term-Shell
+ dev-perl/Tie-IxHash
+ dev-perl/YAML-Syck
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_configure() { :; }
+
+src_compile() {
+ pod2man --name "${PN}" < "${PN}" > "${PN}.1" || die 'creating manpage failed'
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "${PN}"
+ dodoc USAGE
+}