summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-07-08 09:07:50 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-07-08 09:17:04 -0700
commitf4e12ad13f410d8c4354e94207234d0007b8bcaa (patch)
tree2edd671472e034e4ba38652175f944e88a0bffc4 /net-nds
parentdev-libs/gobject-introspection: Enable py3.13 (diff)
downloadgentoo-f4e12ad13f410d8c4354e94207234d0007b8bcaa.tar.gz
gentoo-f4e12ad13f410d8c4354e94207234d0007b8bcaa.tar.bz2
gentoo-f4e12ad13f410d8c4354e94207234d0007b8bcaa.zip
net-nds/nsscache: QA improvements
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/923061
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/nsscache/nsscache-0.49-r1.ebuild (renamed from net-nds/nsscache/nsscache-0.49.ebuild)18
1 files changed, 6 insertions, 12 deletions
diff --git a/net-nds/nsscache/nsscache-0.49.ebuild b/net-nds/nsscache/nsscache-0.49-r1.ebuild
index 7c9dfe0b027a..b0fd6dc60bed 100644
--- a/net-nds/nsscache/nsscache-0.49.ebuild
+++ b/net-nds/nsscache/nsscache-0.49-r1.ebuild
@@ -11,6 +11,7 @@ inherit distutils-r1
DESCRIPTION="commandline tool to sync directory services to local cache"
HOMEPAGE="https://github.com/google/nsscache"
SRC_URI="https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-version-${PV}"
# upstream *sources* say "or later", but upstream metadata does not include the
# 'or later' clause.
@@ -34,12 +35,7 @@ RDEPEND="
>=dev-python/pycurl-7.45.2[${PYTHON_USEDEP}]
s3? ( dev-python/boto3[${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
- dev-python/packaging[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${PN}-version-${PV}"
+ dev-python/packaging[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
@@ -48,19 +44,17 @@ python_prepare_all() {
# Default config tries $PREFIX/config/nsscache.conf
sed -i \
-e '/data_files/{s,.nsscache.conf.,,}' \
- setup.py
+ setup.py \
+ || die
# Upstream forgot to bump the version
sed -i \
-e '/^__version__/s,0.48,0.49,g' \
- nss_cache/__init__.py
+ nss_cache/__init__.py \
+ || die
distutils-r1_python_prepare_all
}
-python_compile() {
- distutils-r1_python_compile
-}
-
python_install() {
distutils-r1_python_install