summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2022-11-28 22:20:09 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2022-11-28 22:22:46 +0100
commit306e7836b66babd6e468a28d6ef6e142ffe77819 (patch)
tree1da6b466805556e94668c4306393603f5ae1e5a3 /net-p2p
parentapp-portage/metagen: Python 3.11 + DistutilsNonPEP517Build + MissingRemoteId (diff)
downloadgentoo-306e7836b66babd6e468a28d6ef6e142ffe77819.tar.gz
gentoo-306e7836b66babd6e468a28d6ef6e142ffe77819.tar.bz2
gentoo-306e7836b66babd6e468a28d6ef6e142ffe77819.zip
net-p2p/qbittorrent: 4.5.0 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.5.0.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index d80dea94b35b..8a1348475f29 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -2,3 +2,4 @@ DIST qbittorrent-4.3.9.tar.gz 8510414 BLAKE2B de98aff6d81f43c3ad87f6c5f800a4488e
DIST qbittorrent-4.4.3.1.tar.gz 7736308 BLAKE2B 9177f0c629418a5f9e7f117b7d1f990181ef910193fed9763f2137cbc91c9de07ad96884d57e96782b5a2f6089fe73d3fab0a2f2f54f72dd8c2cec00dd179e5f SHA512 e3d63c4090e27387f4a5524d0daab26eab70f70ef81ad607e9661e128ccccbf33f2d240cd219bbb1fb138d6e78493ce73055d5128bf888e0ad3949922774efba
DIST qbittorrent-4.4.4.tar.gz 7738480 BLAKE2B 2a3157a732fda6eaff809d3ea717ebcc2cb7f4364cc3209bd1836196541e83cf8c7430b32037a6a6c4f517d17edb576dd80c834185d7cb764567bd5ce699bd52 SHA512 3bd26021f45287ff5b6c9a1629ff470204121c4056d452a5c00bc94b69a198093127916d33797b357eaacdb9ffd01d0de13daecb7503088cde440d5e4895ec3e
DIST qbittorrent-4.4.5.tar.gz 7739170 BLAKE2B b40a3ca63c787e0b9b9aac00a6fef452b461ba36b1ef030bc3cdd5fbefcca42d58ff6c3bd382e49f7937161afc6a37bc2c29de4f804db10c7031b9f1ad5f4e2b SHA512 a2b6ecd9a6f087a7ecaad2774d395ee4b2164cb8540b9f32574640f485fa3fc8688046d30e0179863a0aff1524d69b83c00bc232c7feb9ad737c79a05734ad95
+DIST qbittorrent-4.5.0.tar.gz 8703851 BLAKE2B 1d124921726124650073f5ae2bc078213d82d95b5986145f8570da3af38bc3f70e67046cf22db2e3a196343715b60c0896ed933bec45f5d746e6ad410748223d SHA512 3a7ae1e5d8b92748ea87b3bd07ea76fc19f4ce1c5cfbb76e57dae3e4fee1ca1c4d650db28e9571463c34b9d1af7c7c8475851911398f57e24b395223683727e7
diff --git a/net-p2p/qbittorrent/qbittorrent-4.5.0.ebuild b/net-p2p/qbittorrent/qbittorrent-4.5.0.ebuild
new file mode 100644
index 000000000000..c12b6e9850c3
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.5.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/qBittorrent-release-${PV}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )
+ || ( gui webui )"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/openssl-1.1.1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtxml:5
+ <net-libs/libtorrent-rasterbar-2:=
+ >=sys-libs/zlib-1.2.11
+ dbus? ( dev-qt/qtdbus:5 )
+ gui? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ multibuild_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+
+ -DWEBUI=$(usex webui)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == gui ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant multibuild_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+}