summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-14 23:04:40 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-14 23:05:46 +1100
commit3b33173f06f417136f6fa8eb9176ceb732bfeec9 (patch)
tree59161bbd3aa6ebcb9df844e20633895222210b5f /net-p2p
parentnet-misc/kea: Added live ebuild. (diff)
downloadgentoo-3b33173f06f417136f6fa8eb9176ceb732bfeec9.tar.gz
gentoo-3b33173f06f417136f6fa8eb9176ceb732bfeec9.tar.bz2
gentoo-3b33173f06f417136f6fa8eb9176ceb732bfeec9.zip
net-p2p/pybitmessage: version bump 0.6.3.2
Bug: https://bugs.gentoo.org/647568 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/pybitmessage/Manifest1
-rw-r--r--net-p2p/pybitmessage/pybitmessage-0.6.3.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-p2p/pybitmessage/Manifest b/net-p2p/pybitmessage/Manifest
index fc66f04adbf7..7b5522350a9a 100644
--- a/net-p2p/pybitmessage/Manifest
+++ b/net-p2p/pybitmessage/Manifest
@@ -1,2 +1,3 @@
DIST pybitmessage-0.4.2.tar.gz 547565 BLAKE2B 8cb7bc0407601f06c5d0040fa03372e95c34e21aed79021001f7067b3340c60a08f7ab7d2c6578e78e1f7bf09a5adc5805252a27cf8e1bda27de6d1495382e35 SHA512 5e783243db4f507ec221092f6da18d25bb15a8c83f28aab7c1796a063d2608c0115c9d636cc73b66a09264a4ff69dda9ba373eff81640b1dd9595100dcdc4917
DIST pybitmessage-0.6.2.tar.gz 1053815 BLAKE2B 28ed1a836771318f59986532aaa8b87c0c6d195988f02fc977c3b21b423145cc5b732bc1d4ed9978c26c0edb1c040844c9c00ec4db6418ae1e938bae335ed118 SHA512 4aaa0f6b1cc04de01154bb5c90416901e51abb4465c62269ab07abb7da980ac07f2f548ae7a3780da9f3efe89d3b841b004996c5e33bc2638e58efcbecc8baef
+DIST pybitmessage-0.6.3.2.tar.gz 1118048 BLAKE2B 56245d2b6126fd0b325f20a829d4aa3d89d74fed48863ba236c74b33b074be5c88fd7d70bd08a9b4a1499aaf7e414f55c2f5ca93dca5769eaaf90c2082bc0cac SHA512 57bdbf10417973b4414f1a184b375a2dd6db1a07a6bc5596b5d256589eeae3c7343692be0f0aa681244c550d2b2d91773d9383d97c56eb48562d8099908c0261
diff --git a/net-p2p/pybitmessage/pybitmessage-0.6.3.2.ebuild b/net-p2p/pybitmessage/pybitmessage-0.6.3.2.ebuild
new file mode 100644
index 000000000000..5dc0e77b7621
--- /dev/null
+++ b/net-p2p/pybitmessage/pybitmessage-0.6.3.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+# See https://github.com/Bitmessage/PyBitmessage/pull/952 for
+# why ipv6 is needed at the moment.
+PYTHON_REQ_USE="ipv6,sqlite"
+
+inherit distutils-r1 gnome2-utils
+
+MY_PN="PyBitmessage"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="P2P communications protocol"
+HOMEPAGE="https://bitmessage.org/"
+SRC_URI="https://github.com/Bitmessage/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl ncurses opencl sound"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+# Some of these can be determined from src/depends.py.
+# The sound deps were found in src/bitmessageqt/__init__.py.
+# And src/openclpow.py imports numpy directly, so throw that in too.
+#
+# All of the dependencies that are behind USE flags are detected
+# and enabled automagically, so maybe it would be better if we
+# required them unconditionally?
+RDEPEND="${DEPEND}
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ ncurses? ( dev-python/pythondialog[${PYTHON_USEDEP}] )
+ opencl? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyopencl[${PYTHON_USEDEP}]
+ )
+ sound? ( || (
+ media-sound/gst123
+ media-sound/alsa-utils
+ media-sound/mpg123
+ ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ distutils-r1_src_install
+ dodoc README.md
+
+ # The man page is not installed because it's basically empty.
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}