summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Wilson <sam@binarycake.ca>2024-11-20 12:05:40 -0500
committerSam James <sam@gentoo.org>2024-12-01 11:44:24 +0000
commit5f1e43738efa4381fabfcfb6291b644dbdff7e72 (patch)
treeea822a843c9fc8ec4a8bce9925aea365553cf1a8 /net-p2p
parentdev-util/yamllint: enable py3.13 (diff)
downloadgentoo-5f1e43738efa4381fabfcfb6291b644dbdff7e72.tar.gz
gentoo-5f1e43738efa4381fabfcfb6291b644dbdff7e72.tar.bz2
gentoo-5f1e43738efa4381fabfcfb6291b644dbdff7e72.zip
net-p2p/go-ethereum: package 1.14.12
Signed-off-by: Sam Wilson <sam@binarycake.ca> Closes: https://github.com/gentoo/gentoo/pull/39387 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.14.12.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 0efc274c6bb8..51217f7dc59e 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -3,5 +3,6 @@ DIST go-ethereum-1.10.18.tar.gz 13084436 BLAKE2B 4918f13b131796f928c17e6cbd3ab42
DIST go-ethereum-1.13.14-deps.tar.xz 70373740 BLAKE2B 6bc403f85e024fdeeab8f41ef7f2940cceee11b8f6a1f97dc53cc5dda997f3c97ddcaefac61df196508f00fe61152f21bedc8de9e380fa91245a049c0a93ab58 SHA512 0d6cc6b846dab05acabfa0fc840f2db450a3138f863bf3f99ef83040071260a42fa2dccb88877a0d340e2532241653c32efb783bc67698f316ab1c9291d75330
DIST go-ethereum-1.13.14.tar.gz 13500798 BLAKE2B f5cf0c3f72aedc7d149c5342c2edbcb4310301b4c9b164d65e1e281b8db78c79ca884e9cb41ecd72ed6fbbed34e198cb13fe7cc726856c9f323a4aacc4a2dc17 SHA512 80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc
DIST go-ethereum-1.14.11.tar.xz 169400476 BLAKE2B 0609a7f55c50616fabc41c64bbaff3e051a75a077a6db85a9e8e94dc44c053970d85684a32d7f126f7abc4d4bcb12112bbaf45808f8dcc12f7ae927c9736cd19 SHA512 b4619ff3d44ee411710ed4d69f9a2c38c47d7160011cc8dfd8adb39d999dc682a10204a2ce0cdf5004dcada2300d86588d609a20555506c0066931e694656480
+DIST go-ethereum-1.14.12.tar.xz 169335464 BLAKE2B 9032894035b307c6cd32eb1f1a03613cae895f12ad5c727e292f98dcc345216761e86436f56bdd66aeb2fcc5c43f2f0ea85f646ca19d29ee9a79ca8d8f39b37d SHA512 99bd94d86af1444618bddcc69e0046d7323ab4c248dfa5dd19a46f1684a329a2a1e3dd810f866236f1786560ed29eda57f08aba8e6ce8cb8c2bb14e950509162
DIST go-ethereum-1.14.7.tar.xz 167692372 BLAKE2B 90333516179a126a4972f616152fbf8eb83bb1f75b28ff92665b23d450bc04bba231c4978fada1f472f2205d373fbdf555548db262d8dd09c21730ed9ede74cd SHA512 ba2218c40bc58861a975041f04b822f38275c98cd1ebf0dbcfd0d454ca43d2712df4d35cb3516e503a31ab0f90fc1ba64b2e889e0b82fea8d33dd9dd1d838f13
DIST go-ethereum-1.14.8.tar.xz 167710376 BLAKE2B aa9e5b854bfec55b3b998a22042a3b5a8091341358764d6568f08a936ba19dda1ad9a1a2c0f5728b0f0cc932eee027636653a1e4d2ca613c9eaadddb8cdb08cb SHA512 4bd2bbd34742cb5acce8734414b5d77f49ca9a54885939f932a8889702d9cead3efcf723d75b4e62b0bd3eeabc2ed298b65639da3485ac80eeaf45b7d01fad03
diff --git a/net-p2p/go-ethereum/go-ethereum-1.14.12.ebuild b/net-p2p/go-ethereum/go-ethereum-1.14.12.ebuild
new file mode 100644
index 000000000000..89e866df595a
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.14.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+LONG_VERSION="${PV}+build30503+noble"
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://ppa.launchpadcontent.net/ethereum/ethereum/ubuntu/pool/main/e/ethereum/ethereum_${LONG_VERSION}.tar.xz -> ${P}.tar.xz"
+# Above PPA is listed as an official source here:
+# https://geth.ethereum.org/docs/getting-started/installing-geth#ubuntu-via-ppas
+S="${WORKDIR}/ethereum-${LONG_VERSION}"
+
+LICENSE="GPL-3+ LGPL-3+ MIT || ( BSD GPL-2 ) BSD-2 LGPL-2.1+ Apache-2.0 ISC MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT+=" test"
+
+src_unpack() {
+ default
+ mv "${S}/.mod" "${WORKDIR}/go-mod" || die
+}
+
+src_compile() {
+ go-env_set_compile_environment
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+
+ # TODO: replace with wildcard
+ if use devtools; then
+ dobin build/bin/abidump
+ dobin build/bin/abigen
+ dobin build/bin/blsync
+ dobin build/bin/bootnode
+ dobin build/bin/clef
+ dobin build/bin/devp2p
+ dobin build/bin/era
+ dobin build/bin/ethkey
+ dobin build/bin/evm
+ dobin build/bin/rlpdump
+ fi
+}