summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-06-14 12:16:45 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-06-14 12:40:22 +0200
commit8e3120e38adf1f24472b8c9041ae627b4111c17a (patch)
tree88c5d73d404baa6790b25aba6285cbd7953a336a /net-print
parentapp-emulation/plus42: add 1.1.12, drop 1.1.10 (diff)
downloadgentoo-8e3120e38adf1f24472b8c9041ae627b4111c17a.tar.gz
gentoo-8e3120e38adf1f24472b8c9041ae627b4111c17a.tar.bz2
gentoo-8e3120e38adf1f24472b8c9041ae627b4111c17a.zip
net-print/splix: add 2.0.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/Manifest1
-rw-r--r--net-print/splix/metadata.xml1
-rw-r--r--net-print/splix/splix-2.0.1.ebuild63
3 files changed, 65 insertions, 0 deletions
diff --git a/net-print/splix/Manifest b/net-print/splix/Manifest
index 4df920013eab..4950ef649caf 100644
--- a/net-print/splix/Manifest
+++ b/net-print/splix/Manifest
@@ -1,2 +1,3 @@
DIST samsung-cms-20120312.tar.xz 3354884 BLAKE2B ebff80c7e4ddebb87c46b0d282c64037d7584170ed224931e5b17fc93a76b162bd1b33ed00c59371464dcaef345cf6c33d428aa42c7b67c82958a23384ed0bac SHA512 448f111493540dc93b88d59fa50857bdca2aa9eb772e53c1d227402235d878ad599683d74bc4d815b4789527b5e7ebe207bb0c8fa9194eaf61ca95b78a1444db
DIST splix-2.0.0_p20130826.tar.bz2 127278 BLAKE2B 6a8eb6b15e5208dd4173d50bf2b41d0e0f136057fbb46f36fb68ab1302c0c8a6b735311bc03f15e7afce0de802b3fa62df04ad5cd016532216b67a74e39835c3 SHA512 dda07e24b4321e6c1e3d4fbdd03fcc2b5931465db36ed9d8676a62313c4c64b7cbd58bf41996ddd1ab02086438f225439db0506aca7f0269f6c84e80eff72cb0
+DIST splix-2.0.1.tar.xz 93032 BLAKE2B 82de9e591bda902cee9423e3f626a5b8b13b8ec0e2fd842142b10549d87094316d59c57a005615bf37601ecedf9d5defc59beb5312b4e1269ff1db207c3722bc SHA512 45708d65576e87c9f0c9cc7d4919ea19b1418bb932854b14a80bbcf890e28f7ee11ac64a5b9ccca1b8f4aec803822392ab738329d3e9894ad60b5393bffeef74
diff --git a/net-print/splix/metadata.xml b/net-print/splix/metadata.xml
index 2ea580a8d8e2..3ddb1879ca37 100644
--- a/net-print/splix/metadata.xml
+++ b/net-print/splix/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">splix</remote-id>
+ <remote-id type="github">OpenPrinting/splix</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-print/splix/splix-2.0.1.ebuild b/net-print/splix/splix-2.0.1.ebuild
new file mode 100644
index 000000000000..365ce4c1ab21
--- /dev/null
+++ b/net-print/splix/splix-2.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="https://splix.sourceforge.net/"
+SRC_URI="https://github.com/OpenPrinting/splix/releases/download/${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~voyageur/distfiles/samsung-cms-20120312.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+jbig"
+
+DEPEND=">=app-text/ghostscript-gpl-9.02
+ >=net-print/cups-1.4.0
+ jbig? ( media-libs/jbigkit )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.0_p20130826-algo0x11_le.patch )
+
+src_prepare() {
+ default
+
+ # Move to correct place
+ mv *.ppd ppd/
+ # Honor LDFLAGS
+ sed -e "/[a-z]_LDFLAGS/s/:=.*/:= $\{LDFLAGS\}/" -i module.mk \
+ || die
+}
+
+src_compile() {
+ local options="MODE=optimized"
+ use jbig || options="${options} DISABLE_JBIG=1"
+ emake ${options} PSTORASTER=gstoraster CXX="$(tc-getCXX)" \
+ OPTIM_CFLAGS="${CFLAGS}" OPTIM_CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ gzip "${ED}"/$(cups-config --datadir)/model/*/*.ppd || die
+
+ emake DESTDIR="${D}" CMSDIR="${WORKDIR}"/cms MANUFACTURER=samsung installcms
+ # Add symlinks for xerox and dell models (installed in samsung)
+ dosym $(cups-config --datadir)/profiles/samsung $(cups-config --datadir)/profiles/xerox
+ dosym $(cups-config --datadir)/profiles/samsung $(cups-config --datadir)/profiles/dell
+}
+
+pkg_postinst() {
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+}